Ask Your Question
1

quantum-l3-agent w/quantum-openvswitch will not bring up routing gateway and floating IPs

asked 2013-07-14 19:34:27 -0500

skyrainman gravatar image

updated 2013-07-19 16:57:38 -0500

smaffulli gravatar image

Hello,

I am running the quantum-l3-agent and quantum-openvswitch-agent, however, I can not get router gateway or floating IPs to come up. My VMs can get an IP from DHCP, but they can't reach the outside world, nor can outside reach in.

There are no errors logged in the quantum l3 or openvswitch agent logs. One thing to note that if I add the public network to physnet2, then I can see the IPs come up although they are not useful as I need them to be in physnet1 which is mapped to the br-ex network.

Currently, I have 2 physical networks:

  • physnet1 (public, br-ex)
  • physnet2 (VLANs)

My OS is CentOs 6.4, and my environment information is:

  • (3) Controller w/Quantum/Swift (redundant)
  • Compute Nodes
  • Cinder Node

Network Information

  • eth0 - management
  • eth1 - public
  • eth2 - data/vm

plugin.ini VLAN setup

VLAN Setup

network_vlan_ranges=physnet1,physnet2:900:999 bridge_mappings=physnet1:br-ex,physnet2:br-prv integration_bridge=br-int enable_tunneling=False tenant_network_type=vlan

I followed the documentation for Scenario 1 setup of network at http://docs.openstack.org/trunk/openstack-network/admin/content/under_the_hood_openvswitch.html.

Public Network

+---------------------------+--------------------------------------+
| Field                     | Value                                |
+---------------------------+--------------------------------------+
| admin_state_up            | True                                 |
| id                        | 33534011-ad9c-4443-933d-bd3c596a60dd |
| name                      | Public                               |
| provider:network_type     | flat                                 |
| provider:physical_network | physnet1                             |
| provider:segmentation_id  |                                      |
| router:external           | True                                 |
| shared                    | False                                |
| status                    | ACTIVE                               |
| subnets                   | df85cc4c-6905-4f59-997a-b3ccc9a8606d |
| tenant_id                 | a87b83b13fe84bb398cfdcd51f25f25e     |
+---------------------------+--------------------------------------+

Private Network

+---------------------------+--------------------------------------+
| Field                     | Value                                |
+---------------------------+--------------------------------------+
| admin_state_up            | True                                 |
| id                        | 3b9add85-d596-441b-a559-833482425045 |
| name                      | Private                              |
| provider:network_type     | vlan                                 |
| provider:physical_network | physnet2                             |
| provider:segmentation_id  | 901                                  |
| router:external           | False                                |
| shared                    | False                                |
| status                    | ACTIVE                               |
| subnets                   | 37b7c608-45f9-4fe8-86db-386005f77d7b |
| tenant_id                 | 1d181b2898504500a1d3432cd3a241f8     |
+---------------------------+--------------------------------------+
edit retag flag offensive close merge delete

Comments

I am not using namespaces and router_id is set. Odd thing is, when I run quantum agent-show, it doesn't show router_id, gateway_external_network_id, floatin_ips etc. It only picks up the handle_internal_only_routers, use_namespaces and interface_driver. It was working, then just stopped.

skyrainman gravatar imageskyrainman ( 2013-07-15 02:25:40 -0500 )edit

Also, now I am getting an error when allocating a floating ip: External network dbe6765b-582c-44fc-840a-9e23d35b19f7 is not reachable from subnet 37b7c608-45f9-4fe8-86db-386005f77d7b. Therefore, cannot associate Port 7619517d-0967-49ec-8ab0-f16bd7b758cb with a Floating IP. Did not happen before.

skyrainman gravatar imageskyrainman ( 2013-07-15 06:04:19 -0500 )edit

The router's gateway needs to be set to the external network, and the router needs an interface on the private subnet.

darragh-oreilly gravatar imagedarragh-oreilly ( 2013-07-15 07:16:29 -0500 )edit

thanks, that has been correctly, it may be a bug as it's not saving to the database or showing it in log file when debug is true. Its showing both variables as blank when the agent starts up. But if I changed handle_internal_only_routers, it will pick it up that variable change, just not the other

skyrainman gravatar imageskyrainman ( 2013-07-15 11:32:52 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
1

answered 2013-07-16 02:53:17 -0500

skyrainman gravatar image

I am not sure how it got there, however, the router_id had a dollar sign in front of it which caused the problem.

edit flag offensive delete link more
0

answered 2013-07-15 02:09:34 -0500

darragh-oreilly gravatar image

If you are not using IP namespaces, then you need to set router_id in l3_agent.ini - http://docs.openstack.org/trunk/openstack-network/admin/content/adv_cfg_l3_agent_namespace.html

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2013-07-14 19:34:27 -0500

Seen: 442 times

Last updated: Jul 19 '13