Ask Your Question
1

Create admin fails with Invalid OpenStack Identity Credentials

asked 2014-05-26 03:34:27 -0500

Nikhil Bedare gravatar image

Hi, I am installing the Openstack for the first time.I am following the standard guide to install. While creating the admin user, I get the error as Invalid openStack Identity Credentials.

keystone user-create --name=admin --pass=qlogic --email=nikhil.bedare@qlogic.com WARNING: Bypassing authentication using a token & endpoint (authentication credentials are being ignored). Invalid OpenStack Identity credentials.

The keystone.log shows the following : 5038 WARNING keystone.middleware.core [-] RBAC: Invalid token 5038 WARNING keystone.common.wsgi [-] The request you have made requires authentication. 5038 WARNING keystone.middleware.core [-] RBAC: Invalid token 5038 WARNING keystone.common.wsgi [-] The request you have made requires authentication. 5038 WARNING keystone.middleware.core [-] RBAC: Invalid token

Can somebody please help me out ?

Thanks, Nikhil.

edit retag flag offensive close merge delete

Comments

Did you complete this steps

$ openstack-db --init --service keystone

  $ export SERVICE_TOKEN=$(openssl rand -hex 10)

  $ echo $SERVICE_TOKEN
  38b5a7143cdfd7063f42

  $ export SERVICE_ENDPOINT=http://192.168.1.127:35357/v2.0

  $ echo $SERVICE_TOKEN > /tmp/ks_admin_token

  $ openstack-config --set /etc/keystone/keystone.conf \
    DEFAULT admin_token $SERVICE_TOKEN

  $ keystone-manage pki_setup --keystone-user keystone \
    --keystone-group keystone

  $ chown -R keystone:keystone /etc/keystone/ssl

  $ for i in start enable status; \
    do systemctl $i openstack-keystone; done

  $ keystone service-create --name keystone --type identity \
    --description "Keystone Identity Service"
  +-------------+----------------------------------+
  |   Property  |              Value               |
  +-------------+----------------------------------+
  | description |    Keystone Identity Service     |
  |      id     | b608338394c8443f88d1bf22bd2029de |
  |     name    |             keystone             |
  |     type    |             identity             |
  +-------------+----------------------------------+

  $ keystone endpoint-create --service_id b608338394c8443f88d1bf22bd2029de \
        --publicurl 'http://192.168.1.127:5000/v2.0' \
        --adminurl 'http://192.168.1.127:35357/v2.0' \
        --internalurl 'http://192.168.1.127:5000/v2.0'
  +-------------+-----------------------------------+
  |   Property  |               Value               |
  +-------------+-----------------------------------+
  |   adminurl  | http://192.168.1.127:35357/v2.0 |
  |      id     |  b6ec04d22c4e4dca867d9f0eb5908fca |
  | internalurl |  http://192.168.1.127:5000/v2.0 |
  |  publicurl  |  http://192.168.1.127:5000/v2.0 |
  |    region ...
(more)
dbaxps gravatar imagedbaxps ( 2014-05-26 03:41:46 -0500 )edit

192.168.1.127 should be replaced by your-controller-ip

dbaxps gravatar imagedbaxps ( 2014-05-26 03:43:25 -0500 )edit

Thanks for your help. I followed the steps you mentioned, but it failed at the following : [root@controller ~]# keystone service-create --name keystone --type identity \

--description "Keystone Identity Service" WARNING: Bypassing authentication using a token & endpoint (authentication credentials are being ignored). Invalid OpenStack Identity credentials.

The logfile show the following : 2014-05-26 05:04:17.940 5038 WARNING keystone.openstack.common.db.sqlalchemy.session [-] Database server has gone away: (2006, 'MySQL server has gone away') 2014-05-26 05:04:17.945 5038 WARNING keystone.middleware.core [-] RBAC: Invalid token 2014-05-26 05:04:17.945 5038 WARNING keystone.common.wsgi [-] The request you have made requires authentication.

Am I missing something ?

Thanks, Nikhil

Nikhil Bedare gravatar imageNikhil Bedare ( 2014-05-26 04:06:46 -0500 )edit

Bring back online MySQL ( just clean) && go one more time through keystone setup.
You didn't create openstack-keystone service. That's what you are missing.

dbaxps gravatar imagedbaxps ( 2014-05-26 04:21:21 -0500 )edit

Hi, I made the mqsql up and tried it again. It fails at the same step :(

[root@controller ~]# keystone service-create --name keystone --type identity --description "Keystone Identity Service" Invalid OpenStack Identity credentials.

Logfile show the following : 2014-05-26 05:58:30.577 3953 WARNING keystone.middleware.core [-] RBAC: Invalid token 2014-05-26 05:58:30.578 3953 WARNING keystone.common.wsgi [-] The request you have made requires authentication.

Thanks, Nikhil.

Nikhil Bedare gravatar imageNikhil Bedare ( 2014-05-26 04:59:39 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-05-26 07:12:49 -0500

dbaxps gravatar image
Bring back online MySQL ( just clean) && go one more time through keystone setup.
You didn't create openstack-keystone service. That's what you were missing.
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-05-26 03:34:27 -0500

Seen: 5,807 times

Last updated: May 26 '14