I can not access internet on network node, how can I configure networking on network node. [closed]

asked 2014-05-26 03:11:13 -0600

anonymous user

Anonymous

Hi, I am having problems with icehouse on CentOS 6.5. I followed the following documents during installation. I have changed the IPs according to my own system. http://docs.openstack.org/icehouse/install-guide/install/yum/content/ (http://docs.openstack.org/icehouse/in...) there are three nodes on the system (controller, compute and network). I am using neutron for networking.

I have two problems.

1) when i configure our nodes' networking just like documentation, network node and compute node can't access internet. I tried to ping a site on the internet on both bodes but it failed. Network configuration settings of my system is;

For controller;

eth0 --> 10.10.2.10
eth1 --> 10.10.10.10 (external network)

For compute1;

eth0 --> 10.10.2.11
eth1 --> 10.10.1.11

For Network;

eth0 --> 10.10.2.21
eth1 --> 10.10.1.21
eth2 --> unnumbered

eth0 interfaces in each nodes are used on the management network. These interfaces are connected via switch, also this switch are not connected company network.

eth1 interfaces in conpute1 and network nodes are used on tunnels network. These interfaces are linked back-to-back.

eth2 interface in network node is used for external network. (connect company network)

In my system, all machines ping each other on management network (eth0 interface). Also, eth1 interfaces work fine. But eth2 interface on network node doesn't ping an any site on the internet.

How can I access the internet on network node and compute1 node???

2) The second issue looks like at the first issue. I have just changed eth2 interface on network node. I have gived a static IP (10.10.10.21). After this change, network node ping a site on the internet, but compute1 node still doesn't ping. I have skipped this issue and kept going installation. When I have added bridges (br-int and br-ex) on network, network node doesn't ping a site on the internet.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by rbowen
close date 2016-09-21 15:50:52.068367

Comments

1

did you configure the interface correctly? i believe you might need to add below config to the interface first.

# VM internet Access
auto eth2
iface eth2 inet manual
up ifconfig $IFACE 0.0.0.0 up
up ip link set $IFACE promisc on
down ip link set $IFACE promisc off
down ifconfig $IFACE down

then add eth2 into br-ex. if i'm not mistken you need to restart your network interface before things up again.

and add the static ip address to your br-ex interface. have you tried it?

senyapsudah gravatar imagesenyapsudah ( 2014-05-26 05:42:43 -0600 )edit

Yes I have tried but didn't work.

Firstly, I want to solve first issue. I follow this page http://docs.openstack.org/icehouse/install-guide/install/yum/content/basics-networking-neutron.html (link text) for network structure and set network interfaces on network node according to 'network node' subtitle on the same page. According to this page http://docs.openstack.org/icehouse/install-guide/install/yum/content/basics-neutron-networking-verify.html (link text) all nodes are supposed to be able to access the internet, but my compute node and network node can't access the internet.

nevzat gravatar imagenevzat ( 2014-05-27 01:57:24 -0600 )edit

Hi I had a similar problem with CentOS 6.5. It's solved now, so maybe this thread help you https://ask.openstack.org/en/question...

Greetings ;)

Iván Sixto gravatar imageIván Sixto ( 2014-06-05 03:47:50 -0600 )edit

Your router has to support unnumbered interfaces for this to work

ethode gravatar imageethode ( 2015-04-13 19:20:51 -0600 )edit

Closing: This references a version of OpenStack which has been marked End Of Life - https://releases.openstack.org/ Please open a new question if you're still experiencing this with a more recent version of OpenStack.

rbowen gravatar imagerbowen ( 2016-09-21 15:50:42 -0600 )edit