Ask Your Question
0

Unable to add an image to glance service [closed]

asked 2013-07-14 06:19:11 -0500

bv_arvind gravatar image

I tried follwoing the guide to install openstack and I was stuck at a point trying to add an image to the glance. Upon executing "glance image-create" I get "invalid openstack credentials". However, I have properly created a user name glance and I have mentioned this information in both glance-api and glance-registry. Some one suggested to have the admin IP address changed in the glance-api config file, that dint help either. Can anyone suggest how to debug this further. here are some system config param:

[root@vee-dev-appliance-1 images]# keystone user-list WARNING: Bypassing authentication using a token & endpoint (authentication credentials are being ignored). +----------------------------------+--------+---------+-------+ | id | name | enabled | email | +----------------------------------+--------+---------+-------+ | e59e387866df4238a9162f83017c0793 | admin | True | | | a896d3d3573a46aba848c13bd7926df9 | glance | True | | | 283559a47a384f83b62f703b6d47d774 | nova | True | | +----------------------------------+--------+---------+-------+

[root@vee-dev-appliance-1 images]# keystone service-list WARNING: Bypassing authentication using a token & endpoint (authentication credentials are being ignored). +----------------------------------+----------+--------------+------------------------+ | id | name | type | description | +----------------------------------+----------+--------------+------------------------+ | 73c321cccbce4795a07eb024b4c3702a | glance | image | Image Service | | e6d2590d0dc240e5b26569bafc80bc42 | keystone | identity | Identity Service | | e73f628d4d364eeda14767e0ee025b28 | keystone | identity | Identity Service | | 373e1b093c824a56a2158d47ec0c8bf6 | nova | compute | Compute Service | | 1d254d0d68b2466488855744ba10afd4 | swift | object-store | Object Storage Service | +----------------------------------+----------+--------------+------------------------+

Entry in the /etc/glance/glance-api.conf: [keystone_authtoken] auth_host = 127.0.0.1 auth_port = 35357 auth_protocol = http admin_tenant_name = service admin_user = glance admin_password = glance #admin_tenant_name = %SERVICE_TENANT_NAME% #admin_user = %SERVICE_USER% #admin_password = %SERVICE_PASSWORD%

Environment variable: [root@vee-dev-appliance-1 images]# printenv | grep OS_ OS_SERVICE_TOKEN=c4d73657743cfcf23f82 OS_REGION_NAME=RegionOne OS_SERVICE_ENDPOINT=http://localhost:35357/v2.0 OS_PASSWORD=secrete OS_AUTH_URL=http://127.0.0.1:5000/v2.0/ OS_USERNAME=admin OS_TENANT_NAME=demo

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by koolhead17
close date 2014-06-05 21:29:44.866408

1 answer

Sort by ยป oldest newest most voted
2

answered 2013-08-12 13:13:26 -0500

koolhead17 gravatar image

Arvind,

I suspect the incorrect keystone password you have kept might be the reason for this. My suggestion would be, recheck the every steps of the documentation & follow the procedure.

edit flag offensive delete link more

Comments

For me I had to drop the Keystone user entry for glance and then recreate it and it's role and this fixed it. I suspect I did set the password wrong the first time, perhaps left the instruction manual password in there. Here's the commands I had to issue;

keystone user-list # to get the id

keystone user-delete cbadb6fff68a4165a09ba9db75cc850d

keystone user-create --name=glance --pass=password --email=me@gmail.com

keystone user-role-add --user=glance --tenant=service --role=admin

jame gravatar imagejame ( 2014-06-05 19:33:54 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2013-07-14 06:19:11 -0500

Seen: 408 times

Last updated: Aug 12 '13