Ask Your Question
0

[Error: Unexpected vif_type=binding_failed]

asked 2014-05-22 17:15:49 -0500

FuzzyDog gravatar image

Hi

Our OpenStack installation has gained a fault

[Error: Unexpected vif_type=binding_failed]

When trying to start an instance. This has ocurred after adding a 5th Compute node to the stack. I have checked all the config files a number of times and despite them being identical to their counterparts (with the exception of the node specific items such as eth0 Ip address and eth1 Ip address) nobody is able to start instances.

When launching a new instance it appears to be spawning fine and an IP address is assigned. As soon as the error shows, the IP address is lost from the instance and the instance is un-contactable. An attempt to add a floating IP to the instance reveals that there are no "Ports" to assign to the floating IP to. This has managed to cause our entire installation to fail launching instances which is very worrying and after a large amount of searching, chencking config file I would like to ask for help on this forum.

Thanks

Mark

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-06-25 06:01:08 -0500

FuzzyDog gravatar image

We have found that this can be caused by a couple of issues, As the error popup only seems to show the last error when creating an instance, this can be caused by the flavor chosen to initiate the instance having too little disk space.

what actually resolved this for us though was finding out that the command in the docs for working round the packaging bug had not worked. This is worth checking if you are encountering the same problem.

[From the installation docs, installing networking service on a compute node - Item 1 of the "To finalize the installation" section]

cp /etc/init.d/neutron-openvswitch-agent /etc/init.d/neutron-openvswitch-agent.orig sed -i 's,plugins/openvswitch/ovs_neutron_plugin.ini,plugin.ini,g' /etc/init.d/neutron-openvswitch-agent

System is running fine now, hope this helps someone as it took a lot of head scratching to get this resolved.

edit flag offensive delete link more

Comments

@FuzzyDog, thank you so much for coming back to the forum and posting your solution. I'm not sure how that happened, but re-running that command and restarting all networking services did the trick for me. I was getting the error Failed to bind port... when trying to set up a network. Now it works.

gkeller2 ( 2014-07-14 16:59:43 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Get to know Ask OpenStack

Resources for moderators

Stats

Asked: 2014-05-22 17:15:49 -0500

Seen: 1,889 times

Last updated: Jun 25 '14