VM instance not getting IP configured but allocated [closed]

asked 2014-05-22 06:30:59 -0500

San gravatar image

I have configured 3 node openstack icehouse on Ubunto 14.04, one controller node, one network node and one compute node. VM spwaning gets IP allocated observed from the GUI. Dhcp agent is not throwing any errors. I tried different forums and didn't had any luck to resolve this. Even if I assign the IP manually to VM and not able to ping from any node. GRE based tunneling with single network. No vlan implemented.

Any help to resolve this?

Compute Node "ovs-vsctl show" command output. root@compute1:/var/log/nova# ovs-vsctl show a46caeb6-c737-4ad5-8f7a-0c687e11e90b Bridge br-tun Port br-tun Interface br-tun type: internal Port "gre-c0a80c01" Interface "gre-c0a80c01" type: gre options: {in_key=flow, local_ip="192.168.12.2", out_key=flow, remote_ip="192.168.12.1"} Port patch-int Interface patch-int type: patch options: {peer=patch-tun} Bridge br-int Port "qvoc077069b-bd" Interface "qvoc077069b-bd" Port br-int Interface br-int type: internal Port patch-tun Interface patch-tun type: patch options: {peer=patch-int} ovs_version: "2.0.1" root@compute1:/var/log/nova#

I am able to ping the gateway 192.168.3.1 root@network:/var/log/neutron# ip netns exec qdhcp-31dbd35d-0269-42ae-a08e-3112b0401acd ping -c 1 192.168.3.1 PING 192.168.3.1 (192.168.3.1) 56(84) bytes of data. 64 bytes from 192.168.3.1: icmp_seq=1 ttl=64 time=0.475 ms

--- 192.168.3.1 ping statistics --- 1 packets transmitted, 1 received, 0% packet loss, time 0ms rtt min/avg/max/mdev = 0.475/0.475/0.475/0.000 ms root@network:/var/log/neutron#

VM IP got allocated 192.168.3.16 but not configured on the VM. Manually configured but not pingable.

root@network:/var/log/neutron# ip netns exec qdhcp-31dbd35d-0269-42ae-a08e-3112b0401acd ping -c 1 192.168.3.16 PING 192.168.3.16 (192.168.3.16) 56(84) bytes of data. ^C --- 192.168.3.16 ping statistics --- 1 packets transmitted, 0 received, 100% packet loss, time 0ms

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by rbowen
close date 2016-09-21 15:49:01.106183

Comments

Closing: This references a version of OpenStack which has been marked End Of Life - https://releases.openstack.org/ Please open a new question if you're still experiencing this with a more recent version of OpenStack.

rbowen gravatar imagerbowen ( 2016-09-21 15:48:55 -0500 )edit