Ask Your Question
2

Neutron VXLAN not working with RDO Icehouse and CentOS 6.5

asked 2014-05-20 08:42:39 -0500

cskeys gravatar image

updated 2014-05-22 08:56:48 -0500

larsks gravatar image

I am doing a packstack multi-node installation of RDO Icehouse on CentOS 6.5 using Neutron with VXLAN. After installing, the openvswitch agent dies immediately after starting with this error in /var/log/neutron/openvswitch-agent.log:

2014-05-19 22:20:12.970 11639 TRACE neutron.plugins.openvswitch.agent.ovs_neutron_agent SystemError: Unable to determine kernel version for Open vSwitch with VXLAN support. To use VXLAN tunnels with OVS, please ensure that the version is 1.10 or newer!

This appears to be caused by the fact that CentOS 6.5 does not ship with a kernel with VXLAN support and therefore relies on the openvswitch kernel module to provide VXLAN support. The openvswitch agent attempts to check the version of the openvswitch module to ensure it is at least version 1.10 but the openvswitch module that ships with RHEL/CentOS does not report a version via modinfo.

I am currently working around this issue by manually compiling and installing the Openvswitch 2.1.2 kernel module.

I did not have this problem with RDO Havana on CentOS 6.4 because it appears that packstack would install an openstack kernel (2.6.32-358.123.2.openstack.el6.x86_64) that presumably has working VXLAN support.

Should RDO Icehouse with VXLAN on RHEL/CentOS 6.5 work "out of the box" without manually installing openvswitch?

edit retag flag offensive close merge delete

Comments

Im also stuck with similar error.. did you happen to get any workaround?

ramprasvm gravatar imageramprasvm ( 2014-10-18 08:35:13 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-05-23 04:24:57 -0500

panda gravatar image

updated 2014-05-23 04:25:52 -0500

I don't think it is a real problem with the kernel, but the way the agent checks for a valid kernel version. I opened this bug https://bugs.launchpad.net/neutron/+bug/1322139 upstream to know more. You may want to try to modify the function that checks for a valid kernel to see if that works.

edit flag offensive delete link more

Comments

I forgot to mention this in my original post but I have already tried changing the version check by modifying:

neutron/plugins/openvswitch/common/constants.py:MINIMUM_LINUX_KERNEL_OVS_VXLAN = "3.13.0"

I changed the version to 2.6.32-431 to match the kernel version on RHEL/CentOS 6.5. This keeps the openvswitch agent from dying but VXLAN still does not work. The symptom was that the instances could not talk to the network but I did not troubleshoot much to determine the root of that problem.

The bug report is for RHEL 7 with kernel 3.10. Have the necessary VXLAN capabilities been backported to kernel 2.6.32-431?

cskeys gravatar imagecskeys ( 2014-05-24 00:43:57 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-05-20 08:42:39 -0500

Seen: 1,197 times

Last updated: May 23 '14