Ask Your Question
0

Icehouse RDO install error: Error: /Stage[main]/Keystone::Db::Sync/Exec[keystone-manage db_sync]: Failed to call refresh: keystone-manage db_sync returned 1 instead of one of [0]

asked 2014-05-19 20:56:33 -0500

l-39 gravatar image

updated 2014-08-19 00:31:41 -0500

smaffulli gravatar image

Hi,

I have tried install Icehouse on my CentOS 6.5 via RDO packstack. Got error below:

xx.xx.xx.xx_keystone.pp:                         [ ERROR ]         
Applying Puppet manifests                         [ ERROR ]

ERROR : Error appeared during Puppet run: xx.xx.xx.xx_keystone.pp
Error: /Stage[main]/Keystone::Db::Sync/Exec[keystone-manage db_sync]: Failed to call refresh: keystone-manage db_sync returned 1 instead of one of [0]
You will find full trace in log /var/tmp/packstack/20140519-103001-nPPXFU/manifests/xx.xx.xx.xx_keystone.pp.log
Please check log file /var/tmp/packstack/20140519-103001-nPPXFU/openstack-setup.log for more information

Can some one advice about it? Thanks!

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
1

answered 2014-05-21 08:54:31 -0500

rszabo50 gravatar image

updated 2014-05-22 13:13:37 -0500

smaffulli gravatar image

Issue is with packstack. The problem is all about mysql, which does not get configured properly. I am posting a corrective script onto the RDO forums and will put in a request to do a bit of checking during the packstack run.

There is however, either a flaw in the openstack puppet scripts or a bit of OS setup that needs to be understood.

In /usr/lib/python2.6/site-packages/packstack/puppet/templates/mysql_install.pp :

if ($::fqdn != $::hostname and $::hostname != "localhost") {
    database_user { ["root@${::hostname}", "@${::hostname}"]:
        ensure  => 'absent', require => Class['mysql::config'],
    }
}

fails to invoke properly if you use the command hostname and it returns a fully qualified domain name.

I ended up having to alter my /etc/sysconfig/network file so that the HOSTNAME variable did not include the domain name. like:

HOSTNAME=openstack1

I also had to modify /etc/hosts to so that the line leading with 127.0.0.1 completed with <hostname.domain-name> hostname, like

127.0.0.1   localhost localhost.localdomain localhost4 localhost4.localdomain4 openstack1.rszabo50.net openstack1

I then rebooted and attempted the install again.

edit flag offensive delete link more

Comments

packstack and RDO questions are good here too, no problem. Thanks for answering.

smaffulli gravatar imagesmaffulli ( 2014-05-22 13:14:21 -0500 )edit
0

answered 2014-05-21 23:39:56 -0500

tahder gravatar image

Are you behind proxy? if yes, try to add the host_ip in your no_localhost. How many nodes do you have? or just a single node.

edit flag offensive delete link more
0

answered 2014-05-19 23:11:33 -0500

Liping Mao gravatar image

If you use devstack to deploy stabe-havana, you need to use devstack itself in stable-havana branch.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-05-19 20:56:33 -0500

Seen: 3,522 times

Last updated: Aug 19 '14