Ask Your Question
0

Openstack icehouse in fedora 20 with one NIC and Neutron ml2 gre

asked 2014-05-19 09:30:01 -0500

arindamchoudhury gravatar image

Hi,

I am trying to install openstack icehouse on fedora20. I have only one NIC. I want to configure neutron with ml2 plugin and want to use gre tunnelling.

So, I changed my answer file following way:

CONFIG_NEUTRON_L2_PLUGIN=ml2
CONFIG_NEUTRON_ML2_TYPE_DRIVERS=gre
CONFIG_NEUTRON_ML2_TENANT_NETWORK_TYPES=gre
CONFIG_NEUTRON_ML2_TUNNEL_ID_RANGES=100:1000
CONFIG_NEUTRON_OVS_TENANT_NETWORK_TYPE=gre
CONFIG_NEUTRON_OVS_TUNNEL_RANGES=100:1000
CONFIG_NEUTRON_OVS_TUNNEL_IF=em1

CONFIG_HEAT_CLOUDWATCH_INSTALL=y
CONFIG_HEAT_CFN_INSTALL=y

The installation finishes without any error, but it does not add br-ex.

# ovs-vsctl show
14c348c7-9654-4b33-a9a9-c245c0189b57
    Bridge br-tun
        Port br-tun
            Interface br-tun
                type: internal
        Port patch-int
            Interface patch-int
                type: patch
                options: {peer=patch-tun}
    Bridge br-int
        Port patch-tun
            Interface patch-tun
                type: patch
                options: {peer=patch-int}
        Port "tap8651f69c-f3"
            tag: 3
            Interface "tap8651f69c-f3"
                type: internal
        Port br-int
            Interface br-int
                type: internal
    ovs_version: "2.0.1"

Any help will be highly appreciated.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2014-05-19 11:10:18 -0500

SGPJ gravatar image

updated 2014-05-19 11:10:51 -0500

Can you try doing this: sudo ovs-vsctl --no-wait -- --may-exist add-port br-ex "your nic"

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2014-05-19 09:30:01 -0500

Seen: 230 times

Last updated: May 19 '14