Ask Your Question
0

problem in install keystone

asked 2014-05-19 09:24:06 -0500

porya_ras gravatar image

updated 2014-05-19 11:06:35 -0500

i have problem in install keystone on ubuntu 12.04 in vmwear 7

 dpkg: dependency problems prevent configuration of python-webob:
 python-webob depends on python:any (<< 2.8).
 python-webob depends on python:any (>= 2.7.3-0ubuntu2~).
dpkg: error processing python-webob (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                          dpkg: dependency problems prevent configuration of python-pycadf:
 python-pycadf depends on python-webob; however:
  Package python-webob is not configured yet.
dpkg: error processing python-pycadf (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python-oauthlib:
 python-oauthlib depends on python:any (>= 2.7.3-0ubuntu2~).
 python-oauthlib depends on python:any (<< 2.8).
dpkg: error processing python-oauthlib (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python-urllib3:
 python-urllib3 depends on python:any (>= 2.7.3-0ubuntu2~).
 python-urllib3 depends on python:any (<< 2.8).
dpkg: error processing python-urllib3 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python-requests:
 python-requests depends on python:any (<< 2.8).
 python-requests depends on python:any (>= 2.7.3-0ubuntu2~).
 python-requests dependNo apport report written because the error message indicates its a followup error from a previous failure.
                                                 No apport report written because the error message indicates its a followup error from a previous failure.
                                                                           No apport report written because MaxReports is reached already
                                                         No apport report written because MaxReports is reached already
                                       No apport report written because MaxReports is reached already
                     No apport report written because MaxReports is reached already
   No apport report written because MaxReports is reached already
                                                                 s on python-urllib3 (>= 1.7.1); however:
  Package python-urllib3 is not configured yet.
dpkg: error processing python-requests (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python-keystoneclient:
 python-keystoneclient depends on python-requests (>= 1.1.0); however:
  Package python-requests is not configured yet.
dpkg: error processing python-keystoneclient (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python-keystone:
 python-keystone depends on python-keystoneclient (>= 1:0.3.0); however:
  Package python-keystoneclient is not configured yet.
 python-keystone depends on python-webob (>= 1.0.8); however:
  Package python-webob is not configured yet.
 python-keystone depends on python-oauthlib; however:
  Package python-oauthlib is not configured yet.
 python-keystone depends on python-pycadf; however:
  Package python-pycadf is not configured yet.
dpkg: error processing python-keystone (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of keystone:
 keystone depends on python-keystone (= 1:2014.1-0ubuntu1~cloud1); however:
  Package python-keystone is not configured yet.
dpkg: error processing keystone (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 python-webob
 python-pycadf
 python-oauthlib
 python-urllib3
 python-requests
 python-keystoneclient
 python-keystone
 keystone
E: Sub-process /usr/bin/dpkg returned an error code (1)
edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
1

answered 2014-05-19 12:37:18 -0500

rubicon gravatar image

Looks like some python-dependencies are missing?

apt-get install python-software-properties

Did you issue this command while choosing the repository to use?

edit flag offensive delete link more
0

answered 2014-05-20 05:37:32 -0500

porya_ras gravatar image

updated 2014-05-20 05:38:54 -0500

thank you for help and i search about python-software-properties and i install paython2.3-dev and i problem is solved . :D very very thank you .

edit flag offensive delete link more

Comments

Nemas problemas

rubicon gravatar imagerubicon ( 2014-05-20 05:50:03 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-05-19 09:24:06 -0500

Seen: 846 times

Last updated: May 20 '14