Ask Your Question
0

openvswitch: module verification failed: signature and/or required key missing - tainting kernel

asked 2014-05-19 07:11:50 -0500

anonymous user

Anonymous

Hi,

we have a new havana installation with this configuration: one controller-network node, Ubuntu server 12.04.4, Kernel 3.11.0-20-generic one KVM compute node, Ubuntu server 12.04.4, Kernel 3.11.0-20-generic

we are using standard installation with neutron and Openvswitch 1.10.2 (using GRE)

We are getting this strange error in our kern.log:

openvswitch: module verification failed: signature and/or required key missing - tainting kernel

We encountered this error searching for solutions regarding this neutron error:

2014-04-14 10:30:53.465 29893 ERROR neutron.agent.linux.ovs_lib [-] Unable to execute ['ovs-vsctl', '--timeout=2', 'list-ports', 'br-int']. Exception: 
Command: ['sudo', '/usr/bin/neutron-rootwrap', '/etc/neutron/rootwrap.conf', 'ovs-vsctl', '--timeout=2', 'list-ports', 'br-int']
Exit code: 1
Stdout: ''
Stderr: 'ovs-vsctl: no bridge named br-int\n'
2014-04-14 10:30:53.925 29893 ERROR neutron.agent.linux.ovs_lib [-] Unable to execute ['ovs-ofctl', 'del-flows', 'br-tun', 'table=2,tun_id=1']. Exception: 
Command: ['sudo', '/usr/bin/neutron-rootwrap', '/etc/neutron/rootwrap.conf', 'ovs-ofctl', 'del-flows', 'br-tun', 'table=2,tun_id=1']
Exit code: 1
Stdout: ''
Stderr: 'ovs-ofctl: br-tun is not a bridge or a socket\n'
2014-04-14 10:30:53.991 29893 ERROR neutron.agent.linux.ovs_lib [-] Unable to execute ['ovs-ofctl', 'del-flows', 'br-tun', 'dl_vlan=1']. Exception: 
Command: ['sudo', '/usr/bin/neutron-rootwrap', '/etc/neutron/rootwrap.conf', 'ovs-ofctl', 'del-flows', 'br-tun', 'dl_vlan=1']
Exit code: 1
Stdout: ''
Stderr: 'ovs-ofctl: br-tun is not a bridge or a socket\n'
2014-04-14 10:30:55.453 29893 ERROR neutron.agent.linux.ovs_lib [-] Unable to execute ['ovs-vsctl', '--timeout=2', 'list-ports', 'br-int']. Exception: 
Command: ['sudo', '/usr/bin/neutron-rootwrap', '/etc/neutron/rootwrap.conf', 'ovs-vsctl', '--timeout=2', 'list-ports', 'br-int']
Exit code: 1
Stdout: ''
Stderr: 'ovs-vsctl: no bridge named br-int\n'

Is anyone able to reproduce this situation? We already checked our rootwrap configuration in neutron.conf file, it seems OK. We are also able to manually send ovs list-port commands.

Any suggestion on how to solve our problem will be appreciated.

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-05-27 05:35:17 -0500

Problem solved: switched to Ubuntu server 12.04_03 (Kernel 3.8.0-29-generic) with the same configuration on both controller/network and compute nodes.

It seems the problem was related to an OVS(1.10.2) incompatibility issue with Kernel 3.11.0-20-generic.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-05-19 07:11:50 -0500

Seen: 3,109 times

Last updated: May 27 '14