Ask Your Question
1

Swift client pulling two ports [closed]

asked 2014-05-16 17:03:53 -0500

shade34321 gravatar image

I've installed openstack on three computers. I have one computer, xp, set as the controller and swift proxy and two more storage nodes, vista and seven. XP is also a storage node. I followed the openstack documentation on how to install everything and so far everything but swift is working. Which coincidentally happens to be the one thing I need to work, I installed glance, nova, keystone, and the dashboard. Nova and glance were insalled just for the dashboard access.

After setting up swift I went to verify it worked and ran

swift stat

From there I get this error -

Account HEAD failed: http:// xp:8080:8080/v1/AUTH_dded688dc7894082b59c0b12a86d21ff 401 Unauthorized

I can't figure out where it's getting the extra 8080 from. There is only one config file I can find that has that port in it and it states to have it in there. I did find another question similar to mine but their suggestions don't work. All of my *-server.conf files are set to IP 0.0.0.0 which should be all interfaces. So now I'm not sure what to look for. Here are various important http://paste.openstack.org/show/80643/ (config files) you guys can view. If you need more just let me know. I am also using Ubuntu 14.04 if you were curious. Thanks!

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by SamYaple
close date 2014-05-20 15:21:16.004374

1 answer

Sort by ยป oldest newest most voted
1

answered 2014-05-17 16:46:07 -0500

SamYaple gravatar image

updated 2014-05-17 16:47:22 -0500

I have noticed that as well. I didn't dig into why it said that. It was a cosmetic issue on my end though. I believe it is probably just a bad output on your end as well.

The reason Swift isn't working for you likely has nothing to with what you are seeing there.

It isn't working for you becuase you have not configured swift to use keystone properly. Please put the appropriate setting into the authtoken setting of your proxy configuration.

[filter:authtoken]
paste.filter_factory = keystoneclient.middleware.auth_token:filter_factory

# Delaying the auth decision is required to support token-less
# usage for anonymous referrers ('.r:*').
delay_auth_decision = true

# cache directory for signing certificate
signing_dir = /opt/swift/keystone-signing

# auth_* settings refer to the Keystone server
auth_protocol = http
auth_host = controller
auth_port = 35357

# the service tenant and swift username and password created in Keystone
admin_tenant_name = service
admin_user = swift
admin_password = password
edit flag offensive delete link more

Comments

I actually had all of those in my proxy-server.conf file. But you did lead me to part of my problem. My auth_host name was wrong. I forgot to change it from controller to xp. So you inadvertently fixed part of my issue:) Thanks!

shade34321 gravatar imageshade34321 ( 2014-05-19 17:13:38 -0500 )edit

Right... I was pointing to the section you needed to modify. The issue was you had not configured swift to use keystone properly ;-)

SamYaple gravatar imageSamYaple ( 2014-05-19 19:23:52 -0500 )edit

Oh, thought you were saying it should look like that. Thanks for the help!

shade34321 gravatar imageshade34321 ( 2014-05-20 08:07:21 -0500 )edit

That is what we are here for!

SamYaple gravatar imageSamYaple ( 2014-05-20 15:21:09 -0500 )edit

Hi all, I am also facing the same issue , when I am unning swift stat Account HEAD failed: http://192.168.124.10:8080:8080/v1/AU... 503 Service unavailale. can you help me to resolve this issue, mu conf file data is same as mentioned above

abhi24790 gravatar imageabhi24790 ( 2014-09-12 03:36:18 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-05-16 17:03:53 -0500

Seen: 717 times

Last updated: May 17 '14