in nova-compute on vmware, hostname makes errors when nova host-evacute [closed]

asked 2014-05-16 07:48:06 -0600

etlars gravatar image

my env has 2 clusters, 4 vmware esxi hosts and vcenter working with openstack. each cluster has 2 vmware exsi hosts and 1 nova-compute node(as a vm of vmware).

I tried to

nova host-evacuate --target_host [nova-compute-on-cluster1] [nova-compute-on-cluster2]

but "host name" of nova host-evacuate command makes errors everytime.
all my trials were failed :

  • hostname from nova host-list
  • hypervisor-hostname from hypervisor-list

In kvm environment, there is no error to execute host-evacute with hostname form nova host-list.

Attached logs shows my trials. Please, give me the answers what is the proper hostname for nova-compute-vmware.

root@MGMT-SET1:~# nova-manage version

2014.1

root@MGMT-SET1:~# nova service-list

| nova-network | VMWARE-CLUSTER2-SET1 | internal | enabled | up |

| nova-compute | VMWARE-CLUSTER2-SET1 | VMWARE-ZONE02 | enabled | up |

| nova-network | VMWARE-CLUSTER1-SET1 | internal | enabled | up |

| nova-compute | VMWARE-CLUSTER1-SET1 | VMWARE-ZONE01 | enabled | up |

root@MGMT-SET1:~# nova hypervisor-list

| ID | Hypervisor hostname |

| 7 | domain-c13(cluster2) |

| 8 | domain-c23(cluster1) |

root@MGMT-SET1:~# nova host-list

| host_name | service | zone |

| VMWARE-CLUSTER2-SET1 | network | internal |

| VMWARE-CLUSTER2-SET1 | compute | VMWARE-ZONE02 |

| VMWARE-CLUSTER1-SET1 | network | internal |

| VMWARE-CLUSTER1-SET1 | compute | VMWARE-ZONE01 |

root@MGMT-SET1:~# nova host-evacuate --target_host VMWARE-CLUSTER1-SET1 VMWARE-CLUSTER2-SET1

ERROR: No hypervisor matching 'VMWARE-CLUSTER2-SET1' could be found. (HTTP 404)

root@MGMT-SET1:~# nova host-evacuate --target_host VMWARE-CLUSTER1-SET1\:domain-c23(cluster1) --on-shared-storage VMWARE-CLUSTER2-SET1\:domain-c13(cluster2)

NotFound: No hypervisor matching 'VMWARE-CLUSTER2-SET1:domain-c13(cluster2)' could be found. (HTTP 404) (Request- ID: req-aeb88ae6-ce5f-486f-bc97-2123cf56cc57)

ERROR: No hypervisor matching 'VMWARE-CLUSTER2-SET1:domain-c13(cluster2)' could be found. (HTTP 404) (Request-ID: req-aeb88ae6-ce5f-486f-bc97-2123cf56cc57)

root@MGMT-SET1:~# nova host-evacuate --target_host domain-c23 domain-c13

RESP BODY: {"itemNotFound": {"message": "Compute host domain-c23 not found.", "code": 404}}

| Server UUID | Evacuate Accepted | Error Message |

| e15e4b75-xxx| False | Error while evacuating instance: Compute host domain-c23 not found. (HTTP 404)

| 76aae261-xxx| False | Error while evacuating instance: Compute host domain-c23 not found. (HTTP 404)

| 69e48dc8-xxx| False | Error while evacuating instance: Compute host domain-c23 not found. (HTTP 404)

root@MGMT-SET1:~# nova host-evacuate --target_host domain-c23(cluster1) domain-c13(cluster2)

RESP BODY: {"itemNotFound": {"message": "Compute host domain-c23(cluster1) not found.", "code": 404}}

| Server UUID | Evacuate Accepted | Error Message |

| e15e4b75-xxx | False | Error while evacuating instance: Compute host domain-c23(cluster1) not found. (HTTP 404)

| 76aae261-xxx | False | Error while evacuating instance: Compute host domain-c23(cluster1) not found. (HTTP 404)

| 69e48dc8-xxx | False | Error while evacuating instance: Compute host domain-c23(cluster1) not found. (HTTP 404)

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by rbowen
close date 2016-09-21 15:51:36.292590

Comments

Closing: This references a version of OpenStack which has been marked End Of Life - https://releases.openstack.org/ Please open a new question if you're still experiencing this with a more recent version of OpenStack.

rbowen gravatar imagerbowen ( 2016-09-21 15:51:30 -0600 )edit