Ask Your Question
0

packstack: Error: yum update -y kernel iputils iproute returned 1 instead of one of [0]

asked 2014-05-16 06:20:17 -0600

Gokul Praveen gravatar image

updated 2014-05-16 06:21:09 -0600

I couldnt find a solution. I am using packstack on a fedora 20 machine, so this cant be an optional channel problem. The logs specify a 'unknown' repo problem. I have attached them below. Current release in icehouse as of May 16 2014. Kidnly help !

Applying 10.106.240.209_prescript.pp
10.106.240.209_prescript.pp:                      [ ERROR ]            
Applying Puppet manifests                         [ ERROR ]

ERROR : Error appeared during Puppet run: 10.106.240.209_prescript.pp
Error: yum update -y kernel iputils iproute returned 1 instead of one of [0]

Log file: prescript.pp.log

Warning: Config file /etc/puppet/hiera.yaml not found, using Hiera defaults
Notice: Compiled catalog for localhost.localdomain in environment production in 0.83 seconds
Notice: /Stage[main]/Firewall::Linux::Redhat/Service[iptables]/ensure: ensure changed 'stopped' to 'running'
Notice: /Stage[main]/Packstack::Netns/Exec[netns_dependecy_install]/returns: Loaded plugins: langpacks, priorities, refresh-packagekit
Notice: /Stage[main]/Packstack::Netns/Exec[netns_dependecy_install]/returns: 
Notice: /Stage[main]/Packstack::Netns/Exec[netns_dependecy_install]/returns: 
Notice: /Stage[main]/Packstack::Netns/Exec[netns_dependecy_install]/returns:  One of the configured repositories failed (Unknown),
Notice: /Stage[main]/Packstack::Netns/Exec[netns_dependecy_install]/returns:  and yum doesn't have enough cached data to continue. At this point the only
Notice: /Stage[main]/Packstack::Netns/Exec[netns_dependecy_install]/returns:  safe thing yum can do is fail. There are a few ways to work "fix" this:
Notice: /Stage[main]/Packstack::Netns/Exec[netns_dependecy_install]/returns: 
Notice: /Stage[main]/Packstack::Netns/Exec[netns_dependecy_install]/returns:      1. Contact the upstream for the repository and get them to fix the problem.
Notice: /Stage[main]/Packstack::Netns/Exec[netns_dependecy_install]/returns: 
Notice: /Stage[main]/Packstack::Netns/Exec[netns_dependecy_install]/returns:      2. Reconfigure the baseurl/etc. for the repository, to point to a working
Notice: /Stage[main]/Packstack::Netns/Exec[netns_dependecy_install]/returns:         upstream. This is most often useful if you are using a newer
Notice: /Stage[main]/Packstack::Netns/Exec[netns_dependecy_install]/returns:         distribution release than is supported by the repository (and the
Notice: /Stage[main]/Packstack::Netns/Exec[netns_dependecy_install]/returns:         packages for the previous distribution release still work).
Notice: /Stage[main]/Packstack::Netns/Exec[netns_dependecy_install]/returns: 
Notice: /Stage[main]/Packstack::Netns/Exec[netns_dependecy_install]/returns:      3. Disable the repository, so yum won't use it by default. Yum will then
Notice: /Stage[main]/Packstack::Netns/Exec[netns_dependecy_install]/returns:         just ignore the repository until you permanently enable it again or use
Notice: /Stage[main]/Packstack::Netns/Exec[netns_dependecy_install]/returns:         --enablerepo for temporary usage:
Notice: /Stage[main]/Packstack::Netns/Exec[netns_dependecy_install]/returns: 
Notice: /Stage[main]/Packstack::Netns/Exec[netns_dependecy_install]/returns:             yum-config-manager --disable <repoid>
Notice: /Stage[main]/Packstack::Netns/Exec[netns_dependecy_install]/returns: 
Notice: /Stage[main]/Packstack::Netns/Exec[netns_dependecy_install]/returns:      4. Configure the failing repository to be skipped, if it is unavailable.
Notice: /Stage[main]/Packstack::Netns/Exec[netns_dependecy_install]/returns:         Note that yum will try to contact the repo. when it runs most commands,
Notice: /Stage[main]/Packstack::Netns/Exec[netns_dependecy_install]/returns ...
(more)
edit retag flag offensive close merge delete

Comments

The error says, "One of the configured repositories failed". Are you able to install packages manually? When you ran "yum update ..." in response to dbaxps's question, did you run it on the same host that was reporting this error?

larsks gravatar imagelarsks ( 2014-05-16 06:49:36 -0600 )edit

I didn't answer a question, I just commented it Objection.

dbaxps gravatar imagedbaxps ( 2014-05-16 06:51:52 -0600 )edit

@larsks i tried installing .. it already seems to be latest version according to yum cli and yes i ran it on the same machine ..

Gokul Praveen gravatar imageGokul Praveen ( 2014-05-16 06:54:20 -0600 )edit
1

Have you tried just running packstack again? Maybe there was a transient error accessing a remote repository.

larsks gravatar imagelarsks ( 2014-05-16 07:55:08 -0600 )edit

It is comment !
View for yourself http://wiki.centos.org/PackageManagem...

dbaxps gravatar imagedbaxps ( 2014-05-16 08:38:36 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
-1

answered 2014-05-16 07:51:54 -0600

davide gravatar image

Are you behind a proxy? If so, add your proxy to /etc/yum.conf

proxy=http://....
edit flag offensive delete link more

Comments

yes, i am using a proxy .. but its is all perfectly set in the env varibales .. yum is able to find all other packages .. is it necessary to set proxy in yum.conf as well ?

Gokul Praveen gravatar imageGokul Praveen ( 2014-05-18 23:42:55 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-05-16 06:20:17 -0600

Seen: 820 times

Last updated: May 16 '14