Networking Issue, icehouse - two nodes configuration, nova-network [closed]

asked 2014-05-15 06:42:11 -0500

siouffy gravatar image

Hi everybody,

My problem in short: I'm trying to ping my virtual machine instances from the controller node but i can't to that. However, the opposite is possible, I can ping from the vm instances to the controller node. Please notice I posted this question before and didn't get any responce, that was a week ago and throughout the whole week I'm trying to figure it out, with failure everytime. So please, if you can help or give a hint do that.. Will be much appreciated.

Description:
I've installed a two node OpenStack cluster. A Controller node and Compute node using legacy nova-network. I followed every line on the tutorial provided on the website. Im running the controller and compute nodes as virtual machines each has ubuntu 14.04 (LTS) server installed. OpenStack version : icehouse.

Problem1 (Solved): At the beginning I could not ping the vm instances from the compute node (operation not permitted), neither could ping from one vm instance to the other, but i changed nova.conf - at the compute node - to allow same network traffic, which was set false in the tutorial --> this worked.

Current Problem: I still can't ping from controller node to the vm instances. I also can't ping from controller node to compute node on its external interface.

Notes:
The vm instances are connected to the internet. The controller can ping the compute on the managment interface configured security groups to allow all ICMP (-1 -1)


Netowrk Configuration (Controller)
#management interface
auto eth0
iface eth0 inet static
address 192.168.242.11
netmask 255.255.255.0
gateway 192.168.242.2
dns-nameservers 192.168.242.2

Network Configuration (compute1)
# management interface
auto eth0
iface eth0 inet static
address 192.168.242.31
netmask 255.255.255.0
gateway 192.168.242.2
dns-nameservers 192.168.242.2

#external network interface
auto eth0:0
iface eth0:0 inet manual
up ip link set dev $IFACE up
down ip link set dev $IFACE down


**nova.conf at the compute node -- only nova-network part since i believe might be the probelm here.

network_api_class = nova.network.api.API
security_group_api = nova
firewall_driver = nova.virt.libvirt.firewall.IptablesFirewallDriver
network_manager = nova.network.manager.FlatDHCPManager
network_size = 254
allow_same_net_traffic = True
multi_host = True
send_arp_for_ha = True
share_dhcp_address = True
force_dhcp_release = True
flat_network_bridge = br100
flat_interface = eth0:0
public_interface = eth0:0

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by rbowen
close date 2016-09-21 15:52:47.769906

Comments

Closing: This references a version of OpenStack which has been marked End Of Life - https://releases.openstack.org/ Please open a new question if you're still experiencing this with a more recent version of OpenStack.

rbowen gravatar imagerbowen ( 2016-09-21 15:52:43 -0500 )edit