Ask Your Question
0

How to let tgtd listen on a specific interface

asked 2014-05-14 05:40:26 -0500

pci_tb gravatar image

updated 2014-05-14 05:41:08 -0500

After an install of OpenStack (Icehouse on Ubuntu 14.04 LTS) all kind of services first listen on 0.0.0.0 rather than on the network they belong to. I managed to configure all services to listen on the right interfaces, except tgtd/cinder-volume.

lsof | grep tgtd.*LISTEN
tgtd      2547       root    7u     IPv4    16948      0t0        TCP *:iscsi-target (LISTEN)
tgtd      2547       root    8u     IPv6    16949      0t0        TCP *:iscsi-target (LISTEN)

So how to get this service restricted to e.g. 10.0.0.10? cinder.conf offers a "iscsi_ip_address" option, but using this option does not change anything in the listening behaviour of tgtd. tgt would have the portal option for that purpose but no idea on how to make it the default. Any ideas? Hints?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2015-01-25 06:44:45 -0500

Example: to bind tgtd to a specific address and port

tgtd --iscsi portal=192.0.2.1:3260

Adjust your startup script as needed to gain those desired results.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-05-14 05:40:26 -0500

Seen: 1,149 times

Last updated: Jan 25 '15