Ask Your Question
0

route private ips to internet

asked 2014-05-13 16:04:05 -0500

vbarba gravatar image

I need to assign public ips directly to my instances (not using floating ips). The packstack installation out-of-the-box do not enable dhcp on the public_net and then the ips are not assigned to the instances. How could I solve this?

To be clear I need this: --------- eth0 (192.168.66.1) | | (br0 - 192.168.55.1) ----------------- VM (192.168.55.2) VM (192.168.55.3)

VM get ip by dhcp and gw is 192.168.55.1

eth0 and br0 have ip_forwarding enabled.

Thank you in advance.

Regards, Victor

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-05-14 03:29:50 -0500

bishoy gravatar image

To make your instances take public ips inside on the machine. You will have to use your network type in the Neutron configuration is vlans. And don't forget you will need to configure a switch with all the networks you will create on the openstack(vlans networks).

edit flag offensive delete link more

Comments

Sorry to not be clear. I mean that I need routing between the private ips assigned to the instance.

vbarba gravatar imagevbarba ( 2014-05-14 14:27:15 -0500 )edit

you can do that as well. you can route between private networks and machines by putting routing rules while creating the networks in the wizzard or using cli

bishoy gravatar imagebishoy ( 2014-10-14 10:48:29 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2014-05-13 16:04:05 -0500

Seen: 76 times

Last updated: May 14 '14