Ask Your Question
0

Unknown provider:physical_network physnet1 while create a public external network

asked 2014-05-13 10:29:20 -0500

Eli Qiao gravatar image

updated 2014-05-14 06:50:59 -0500

darragh-oreilly gravatar image

I follow this doc to create a networking. but failed and get error message "Unknown provider:physical_network physnet1"

http://docs.openstack.org/admin-guide-cloud/content/under_the_hood_openvswitch.html#under_the_hood_openvswitch_scenario1_network

configure file on network node:

[root@stack-kvm110 ~(keystone_admin)]# grep phy /etc/neutron/plugin.ini 
network_vlan_ranges = physnet2:101:110
bridge_mappings = physnet1:br-ex,physnet2:br-eth1

configure file on compute node:

[root@stack-01 ~]# grep phy /etc/neutron/plugin.ini 
network_vlan_ranges = physnet2:101:110
bridge_mappings = physnet2:br-eth1

log message on networking node:

grep physnet1 /var/log/neutron/openvswitch-agent.log
2014-05-13 23:14:21.981 22925 INFO neutron.plugins.openvswitch.agent.ovs_neutron_agent [-] Mapping physical network physnet1 to bridge br-ex
2014-05-13 23:14:29.547 23107 INFO neutron.plugins.openvswitch.agent.ovs_neutron_agent [-] Mapping physical network physnet1 to bridge br-ex

Did I miss something ?

I check the source code of _process_provider_create in github

if network_type in [constants.TYPE_VLAN, constants.TYPE_FLAT]:
    if physical_network_set:
        if physical_network not in self.network_vlan_ranges:
            msg = _("Unknown provider:physical_network "
                    "%s") % physical_network
            raise q_exc.InvalidInput(error_message=msg)

neutron looks for physical_network defined in network_vlan_ranges, which is defined in /etc/neutron/plugin.ini

network_vlan_ranges = physnet2:101:110

it complains that can not find physical_network in the configuration file.

it is opposite with the guide of http://docs.openstack.org/admin-guide... ( http://docs.openstack.org/admin-guide... )

[ovs] tenant_network_type = vlan network_vlan_ranges = physnet2:101:110 integration_bridge = br-int bridge_mappings = physnet1:br-ex,physnet2:br-eth1 I am quite confused!

edit retag flag offensive close merge delete

Comments

The example is using a flat provider network for the external network named "public". I think there is a mistake and the line in the config file on the host running the neutron server should be network_vlan_ranges = physnet1,physnet2:101:110

darragh-oreilly gravatar imagedarragh-oreilly ( 2014-05-14 03:23:49 -0500 )edit

hi darragh, I have found the answer already by reading the code. but still thanks for your answer.

my bad, I am quite believe in the example provided by the document. if you are thinking this is a error in the doc, where we put the feed back?

thanks Eli.

Eli Qiao gravatar imageEli Qiao ( 2014-05-14 03:32:10 -0500 )edit

I'll need to look into it more. There are two ways the router can be linked to the external network. The original way put the qg- interface on br-ex and that's what the diagram shows and what the note about the veth pair implies. The second way is to use the provider mappings, then the qg- interface will be put in br-int. That is what the neutron net-create --provider:network_type flat --provider:physical_network physnet1 --router:external=True does. So the doc is mixed up.

darragh-oreilly gravatar imagedarragh-oreilly ( 2014-05-14 06:25:56 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2019-01-20 01:04:40 -0500

amer.hwitat gravatar image

I have the same problem .. I checked br-ex it's state is Unknown ... in (ip a) command

maybe this is the problem ... I tried to fix the interface for the bridge br-ex but still it doesn't get fixed ...

systemctl status network

shows that ovs is not working fine or their is a duplicate bridge I have deleted the bridge and again , and configured the icfcg-eno and br-ex and still I get unknown for the interface with restarting the openvswitch and network and enabling network service .. it was not native ... it says ...

so ... stuck on this one maybe it's the problem for this Error of unknown provider, some other thing I have successfully created the bridge with no problems before the installation of packstack ... it's not the way I know but I did it .. maybe this is the other problem ... because I had earlier installations and it permitted creating External Networks on the system ...

Best of all guys

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-05-13 10:29:20 -0500

Seen: 5,336 times

Last updated: May 14 '14