Ask Your Question
1

Connection to neutron failed: Maximum attempts reached

asked 2014-05-13 08:09:57 -0500

kgrvamsi gravatar image

I have started a Multi node Setup of the Openstack Havana Installation on Ubuntu 12.04LTS 64bit and here is the architecture which i'm planning for

Horizon Dashboard(Nat-192.168.72.132) ---->Rabbit MQ(Nat-192.168.72.132)----->Neutron(Nat-192.168.72.131)

I'm using Vmware Workstation for this Setup to get the result set from the keystone through the following command

kgrvamsi@neutron:~$ neutron agent-list

But i get this error

#Connection to neutron failed: Maximum attempts reached

Here is my network Interfaces file

The loopback network interface

auto lo
iface lo inet loopback

auto br-ex
iface br-ex inet static
address 192.168.72.131
netmask 255.255.255.0
gateway 192.168.72.2
dns-nameservers 8.8.8.8

VM internet Access

auto eth0
iface eth0 inet manual
up ifconfig $IFACE 0.0.0.0 up
up ip link set $IFACE promisc on
down ip link set $IFACE promisc off
down ifconfig $IFACE down

Can anyone help me out whats the problem behind this?

edit retag flag offensive close merge delete

Comments

Is Neutron Server running ?

dbaxps gravatar imagedbaxps ( 2014-05-13 08:53:33 -0500 )edit

How looks on Neutron Server Node

    [root@dfw02 neutron(keystone_admin)]$ iptables-save | grep neutron | grep ACCEPT
    -A INPUT -p tcp -m multiport --dports 9696 -m comment --comment "001 neutron incoming" -j ACCEPT
    [root@dfw02 neutron(keystone_admin)]$ netstat -lntp | grep 9696
    tcp        0      0 0.0.0.0:9696            0.0.0.0:*               LISTEN      1239/python
   [root@dfw02 neutron(keystone_admin)]$ ps -ef | grep 1239
neutron   1239     1  0 10:22 ?        00:03:39 /usr/bin/python /usr/bin/neutron-server --config-file /usr/share/neutron/neutron-dist.conf --config-file /etc/neutron/neutron.conf --config-file /etc/neutron/plugin.ini --log-file /var/log/neutron/server.log
dbaxps gravatar imagedbaxps ( 2014-05-13 08:56:33 -0500 )edit

3 answers

Sort by ยป oldest newest most voted
3

answered 2014-05-13 15:08:42 -0500

SGPJ gravatar image

updated 2014-05-13 15:08:56 -0500

try restarting neutron: service openstack-neutron restart

service openstack-neutron-dhcp-agent restart

check all your process are running.

edit flag offensive delete link more

Comments

Just a side note: this syntax is not present anymore in OpenStack Juno - Ubuntu 14.04 (correct me if I am wrong). Correct syntax is service neutron-dhcp-agent-restart

Luigi gravatar imageLuigi ( 2015-09-04 07:56:43 -0500 )edit
0

answered 2014-07-07 20:40:15 -0500

dwyaneini gravatar image

updated 2014-07-07 20:40:30 -0500

I also get the failure. Make sure that all services about neutron are running.

edit flag offensive delete link more
0

answered 2014-08-01 02:43:07 -0500

Hi please check your neutron.conf. Be sure there is no space on the beginning of uncommented line. then restart neutron-server. Hope this work!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-05-13 08:09:57 -0500

Seen: 4,842 times

Last updated: Jul 07 '14