Ask Your Question
2

Ping works but cannot SSH the Instance/Stack

asked 2014-05-13 02:37:55 -0500

I am facing a little issue while sshing to the stack that i have launched successfully. I have launched a stack with the key named "heat_key" and changed its permissions by the command

chmod 600 heat_key

But when I try to ssh to the stack using its IP it gives the following error.

Permission denied (publickey,gssapi-keyex,gssapi-with-mic).

I am able to ping the same IP but unable to ssh. i can obtain a list of keys through nova using

nova keypair-list

which enlists the key i have made.

The error is related to keys. i guess the keys are not matching or there is some other issue. Any Help would be appreciated!!

edit retag flag offensive close merge delete

Comments

What is an exact ssh command ?

dbaxps gravatar imagedbaxps ( 2014-05-13 02:48:57 -0500 )edit

ssh -i heat_key user@X.X.X.X where user is ec2-user and X.X.X.X denotes the IP assigned to the instance

Syed Awais Ali gravatar imageSyed Awais Ali ( 2014-05-13 12:07:52 -0500 )edit

The authenticity of host '10.0.0.6 (10.0.0.6)' can't be established. RSA key fingerprint is fe:5b:c6:a0:5a:87:ed:e6:a3:19:84:88:45:90:cf:f5. Are you sure you want to continue connecting (yes/no)? yes

so when i type in YES the above stated error occurs.. means something is wrong with the keys.

Syed Awais Ali gravatar imageSyed Awais Ali ( 2014-05-13 12:49:02 -0500 )edit

Try
$ nova keypair-add oskey25 > oskey25.priv
$ chmod 600 oskey25.priv
Launch instance with oskey25

dbaxps gravatar imagedbaxps ( 2014-05-13 13:01:43 -0500 )edit

i did the same process for heat_key. I repeated the process that you mentioned. But this time the stack made in not even pingable. i cannot ping the new stack. Its IP is 10.0.0.11. so if i cannot ping it, i cannot ssh it. ssh -i oskey25.priv ec2-user@10.0.0.11 ssh: connect to host 10.0.0.11 port 22: No route to host

Syed Awais Ali gravatar imageSyed Awais Ali ( 2014-05-13 14:15:55 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-06-24 00:10:04 -0500

Vinoth gravatar image

Adding / uncommenting the following parameters in /etc/sh/ssh_conf file of client side OS solved the issue.

MACs hmac-md5,hmac-sha1,umac-64@openssh.co...

Add the above parameter in client OS( from where you gonna take ssh of openstack VMs) and also add it to VMs, if you wanna take ssh of other machines from your VM.

edit flag offensive delete link more

Comments

Hi, i have the same problem, I tried this but it does not work. Can you help me? Thanks.

Salvo gravatar imageSalvo ( 2014-12-12 10:55:57 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2014-05-13 02:37:55 -0500

Seen: 1,192 times

Last updated: Jun 24 '14