Ask Your Question
0

neutron network issue with icehouse centos installation guide

asked 2014-05-12 15:32:32 -0500

ask_icehouse gravatar image

I am following the icehouse installation guide, http://docs.openstack.org/icehouse/install-guide/install/yum/content/neutron_initial-networks-verify.html (http://docs.openstack.org/icehouse/in...) . VMs can get IP from the private and public network. I can't acces neither the private or the public network. I can not ping the router address 10.10.40.21. ip netns returns nothing. sec-group is blank also. Thanks for your help.

[root@ice-nova ~]# nova list
+--------------------------------------+------+--------+------------+-------------+----------------------+
| ID                                   | Name | Status | Task State | Power State | Networks             |
+--------------------------------------+------+--------+------------+-------------+----------------------+
| a6d876b1-d926-4d15-b961-ccf0d88737ec | AA   | ACTIVE | -          | Running     | demo-net=192.168.1.2 |
+--------------------------------------+------+--------+------------+-------------+----------------------+

[root@ice-nova ~]# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.122.0   0.0.0.0         255.255.255.0   U     0      0        0 virbr0
169.254.0.0     0.0.0.0         255.255.0.0     U     1002   0        0 eth0
169.254.0.0     0.0.0.0         255.255.0.0     U     1003   0        0 eth1
172.20.0.0      0.0.0.0         255.255.0.0     U     0      0        0 eth0
10.0.0.0        0.0.0.0         255.0.0.0       U     0      0        0 eth1
0.0.0.0         172.20.0.250    0.0.0.0         UG    0      0        0 eth0
[root@ice-nova ~]# neutron port-list
+--------------------------------------+------+-------------------+------------------------------------------------------------------------------------+
| id                                   | name | mac_address       | fixed_ips                                                                          |
+--------------------------------------+------+-------------------+------------------------------------------------------------------------------------+
| 97b9438f-da39-4ec4-83ef-cde0e60151b8 |      | fa:16:3e:a4:ac:9a | {"subnet_id": "98ee14d2-d571-4302-93e6-7eb9aea86d09", "ip_address": "10.10.40.21"} |
| a858b33e-c055-43e7-8bff-b96efafbd59c |      | fa:16:3e:c8:fc:cc | {"subnet_id": "4479dbb4-403e-490d-bb6a-19142ac88c06", "ip_address": "192.168.1.1"} |
| d4d353cf-b2c7-4e78-8e3d-736e0828e8b8 |      | fa:16:3e:8e:95:fc | {"subnet_id": "4479dbb4-403e-490d-bb6a-19142ac88c06", "ip_address": "192.168.1.2"} |
+--------------------------------------+------+-------------------+------------------------------------------------------------------------------------+


[root@ice-neutron ~]# neutron net-list
+--------------------------------------+----------+-----------------------------------------------------+
| id                                   | name     | subnets                                             |
+--------------------------------------+----------+-----------------------------------------------------+
| 9d54586d-d593-424e-86ba-0a464b475e07 | ext-net  | 98ee14d2-d571-4302-93e6-7eb9aea86d09 10.10.40.0/24  |
| e60ddc93-3598-4bb5-83b4-5dbca9a3cfeb | demo-net | 4479dbb4-403e-490d-bb6a-19142ac88c06 192.168.1.0/24 |
+--------------------------------------+----------+-----------------------------------------------------+
[root@ice-neutron ~]# neutron subnet-list
+--------------------------------------+-------------+----------------+--------------------------------------------------+
| id                                   | name        | cidr           | allocation_pools                                 |
+--------------------------------------+-------------+----------------+--------------------------------------------------+
| 4479dbb4-403e-490d-bb6a-19142ac88c06 | demo-subnet | 192.168.1.0/24 | {"start": "192.168.1.2", "end": "192.168.1.254"} |
| 98ee14d2-d571-4302-93e6-7eb9aea86d09 | ext-subnet  | 10.10.40.0/24  | {"start": "10.10.40.20", "end": "10.10.40.100"}  |
+--------------------------------------+-------------+----------------+--------------------------------------------------+
[root@ice-neutron ~]# neutron router-list
+--------------------------------------+-------------+-----------------------------------------------------------------------------+
| id                                   | name        | external_gateway_info                                                       |
+--------------------------------------+-------------+-----------------------------------------------------------------------------+
| 3cf1ef0c-098e-462c-9abc-79aa99fc641d | demo-router | {"network_id": "9d54586d-d593-424e-86ba-0a464b475e07", "enable_snat": true} |
+--------------------------------------+-------------+-----------------------------------------------------------------------------+
[root@ice-neutron ~]# neutron net-show ext-net
+---------------------------+--------------------------------------+
| Field                     | Value                                |
+---------------------------+--------------------------------------+
| admin_state_up            | True                                 |
| id                        | 9d54586d-d593-424e-86ba-0a464b475e07 |
| name                      | ext-net                              |
| provider:network_type     | gre                                  |
| provider:physical_network |                                      |
| provider:segmentation_id  | 1                                    |
| router:external           | True                                 |
| shared                    | True                                 |
| status                    | ACTIVE                               |
| subnets                   | 98ee14d2-d571-4302-93e6-7eb9aea86d09 |
| tenant_id                 | 7e815c96701c41dc9ff8dbcbd4eacbe6     |
+---------------------------+--------------------------------------+
[root@ice-neutron ~]# neutron subnet-show ext-subnet
+------------------+-------------------------------------------------+
| Field            | Value                                           |
+------------------+-------------------------------------------------+
| allocation_pools | {"start": "10.10.40.20", "end": "10.10.40.100"} |
| cidr             | 10.10.40.0/24                                   |
| dns_nameservers  |                                                 |
| enable_dhcp      | False                                           |
| gateway_ip       | 10.10.40.1                                      |
| host_routes      |                                                 |
| id               | 98ee14d2-d571-4302-93e6-7eb9aea86d09            |
| ip_version       | 4                                               |
| name             | ext-subnet                                      |
| network_id       | 9d54586d-d593-424e-86ba-0a464b475e07            |
| tenant_id        | 7e815c96701c41dc9ff8dbcbd4eacbe6                |
+------------------+-------------------------------------------------+
[root@ice-neutron ~]# neutron floatingip-list

[root@ice-neutron ~]# ovs-vsctl show
0ef671f3-1085-4bca-9c6a-e7f2a7c11111
    Bridge br-int
        Port br-int
            Interface br-int
                type: internal
    Bridge br-ex
        Port "eth2"
            Interface "eth2"
        Port br-ex
            Interface br-ex
                type: internal
    ovs_version: "1.11.0"

[root@ice-neutron ~]# ovs-dpctl show
system@ovs-system:
    lookups: hit:601 missed:185 lost:0
    flows: 0
    port 0: ovs-system (internal)
    port 1: br-ex (internal)
    port 2: eth2
    port 3: br-int (internal)
[root@ice-neutron ~]# ifconfig -a
br-ex     Link encap:Ethernet  HWaddr 00:50:56:A1:00:0F  
          inet6 addr: fe80::885c:cfff:feb5:162d/64 Scope:Link
          UP BROADCAST ...
(more)
edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
0

answered 2014-05-13 02:27:15 -0500

dbaxps gravatar image

updated 2014-05-13 02:46:07 -0500

This might the first reason :-

    root@ice-neutron ~]# nova secgroup-list-rules default 
    +-------------+-----------+---------+----------+--------------+
    | IP Protocol | From Port | To Port | IP Range | Source Group | 
    +-------------+-----------+---------+----------+--------------+
    |             |           |         |          | default      |
    |             |           |         |          | default      |
    +-------------+-----------+---------+----------+--------------+

To fix it run :-
    # .   keystonerc_admin
    # nova secgroup-add-rule default icmp -1 -1 0.0.0.0/0
    # nova secgroup-add-rule default tcp 22 22 0.0.0.0/0

OR as particular tenant

     $ neutron security-group-rule-create --protocol icmp \
      --direction ingress --remote-ip-prefix 0.0.0.0/0 default
     $ neutron security-group-rule-create --protocol tcp \
      --port-range-min 22 --port-range-max 22 \
      --direction ingress --remote-ip-prefix 0.0.0.0/0 default
edit flag offensive delete link more

Comments

Thanks dbaxps for your suggestion. I did what you suggested .

[root@ice-neutron ~]# nova secgroup-list-rules default
+-------------+-----------+---------+-----------+--------------+
| IP Protocol | From Port | To Port | IP Range  | Source Group |
+-------------+-----------+---------+-----------+--------------+
|             |           |         |           | default      |
|             |           |         |           | default      |
| icmp        | -1        | -1      | 0.0.0.0/0 |              |
| tcp         | 22        | 22      | 0.0.0.0/0 |              |
+-------------+-----------+---------+-----------+--------------+

However I was wrong about the DHCP. Horizon showed instances with DHP addresses. I assumed the instances must have a working network. But ater I got on the VM's console, I found that it did not have an IP. Do you know how to debug DHCP ?

[root@ice-neutron ~]# neutron subnet-show demo-subnet
+------------------+--------------------------------------------------+
| Field            | Value                                            |
+------------------+--------------------------------------------------+
| allocation_pools | {"start": "192.168.1.2", "end": "192.168.1.254"} |
| cidr             | 192.168.1.0/24                                   |
| dns_nameservers  |                                                  |
| enable_dhcp      | True                                             |
| gateway_ip       | 192.168.1.1                                      |
| host_routes      |                                                  |
| id               | 4479dbb4-403e-490d-bb6a-19142ac88c06             |
| ip_version       | 4                                                |
| name             | demo-subnet                                      |
| network_id       | e60ddc93-3598-4bb5-83b4-5dbca9a3cfeb             |
| tenant_id        | 6b9bcdc97d9042d5a8d6dd5f8294ba26                 |
+------------------+--------------------------------------------------+
ask_icehouse gravatar imageask_icehouse ( 2014-05-13 09:16:00 -0500 )edit

OK. Now:-
$ ip netns list

dbaxps gravatar imagedbaxps ( 2014-05-13 09:21:45 -0500 )edit

This report
[root@ice-neutron ~]# ovs-vsctl show
0ef671f3-1085-4bca-9c6a-e7f2a7c11111
Bridge br-int
Port br-int
Interface br-int
type: internal
Bridge br-ex
Port "eth2"
Interface "eth2"
Port br-ex
Interface br-ex
type: internal
ovs_version: "1.11.0"
doesn't look good to me.
There is no tap-devices attached to br-int . It cannot work as required,

dbaxps gravatar imagedbaxps ( 2014-05-13 09:34:56 -0500 )edit

What reports ?
[root@dfw02 ~(keystone_andrew)]$ ovs-vsctl list-ports br-int
Should look like :-

[root@dfw02 ~(keystone_andrew)]$ ovs-vsctl list-ports br-int
patch-tun
tap343b0090-24
tap40dd712c-e4
tap52247b0b-d9
tapa2f724d1-74
tape031db6b-d0
tapf933e768-42

dbaxps gravatar imagedbaxps ( 2014-05-13 10:46:07 -0500 )edit

with two instances running

[root@ice-nova qemu]# ovs-vsctl list-ports br-int
patch-tun
qvo1e3e52f6-1b
qvo377c427d-8d

with one instance running

[root@ice-nova qemu]# ovs-vsctl list-ports br-int
patch-tun
qvo377c427d-8d

and my "ip netns list" returns blank.

ask_icehouse gravatar imageask_icehouse ( 2014-05-13 12:28:43 -0500 )edit
0

answered 2014-05-15 05:39:55 -0500

vikram_it gravatar image

I also have same problem , I tried the above steps but still problem could not be resolved . If anyone has solved this issue please update the comment.

Many thanks

edit flag offensive delete link more
0

answered 2014-05-20 10:56:25 -0500

ask_icehouse gravatar image

dbaxps you are correct. I messed up my configuration at many places. I ran the command below without replace the IP. openstack-config --set /etc/neutron/plugins/ml2/ml2_conf.ini ovs \ local_ip INSTANCE_TUNNELS_INTERFACE_IP_ADDRESS

Now the instance can at least get private IP and VNC works also.
It still can not use the "ext-net" ovs-vsctl show has one tap under br-int and zero in br-ex . I will work on it more.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-05-12 15:32:32 -0500

Seen: 807 times

Last updated: May 20 '14