Ask Your Question
1

Devstack - Heat Image Image is not active [closed]

asked 2014-05-12 01:57:46 -0600

I am running into a problem when launching a stack

Create_Failed: Resource CREATE failed: BadRequest: Image 7ae5ae5e-a44c-4551-8c2e-e5518b32f232 is not active. (HTTP 400) (Request-ID: req-4a956591-b4c9-404e-ab02-a976108c6474)

I have followed the process to launch stack on devstack from http://docs.openstack.org/developer/heat/getting_started/on_devstack.html (this) post:

But the stack launch fails and gives the above error when i hover mouse in GUI of openstack on the instance.

Let me state here that i have added proper image in glance DB by the command:

glance image-create --name F17-x86_64-cfntools --disk-format qcow2 --container-format bare --is-public True --copy-from http://fedorapeople.org/groups/heat/prebuilt-jeos-images/F17-x86_64-cfntools.qcow2 (http://fedorapeople.org/groups/heat/p...)

Any help is appreciated!! Thanks

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Syed Awais Ali
close date 2014-05-12 08:11:44.757610

Comments

1

Which is the status of your F17-x86_64-cfntools image in the GUI 'Image & Snapshot' section? Is it possible that glance is still saving your image?

Antonio G. gravatar imageAntonio G. ( 2014-05-12 04:43:43 -0600 )edit

By default the glance doesnot have the image that i am going to stack. I first manually add the image in glance using glance image-create command. Then i execute the stack create command. so image does exists in DB. but the error is related to the activeness of image. it gives HTTP400 meaning unreachable.

Syed Awais Ali gravatar imageSyed Awais Ali ( 2014-05-12 04:52:39 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
2

answered 2014-05-12 08:10:29 -0600

OK so the error occurs when you add image and immediately try to create stack using that image. You should first see the image's status either from Openstack GUI's "Image" section or by running the following command

glance image-list

If its Active then try to create stack otherwise it would give the above stated error. I was trying to add image (and still in process) and immediately trying to create stack that's why it was giving the error.

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-05-12 01:57:46 -0600

Seen: 492 times

Last updated: May 12 '14