Ask Your Question
2

cinder-volume localhost:5672 unreachable

asked 2013-07-08 10:06:19 -0500

shoubam gravatar image

I am using devstack on ubuntu 12.04. When starting the rejoin-stack.sh after a reboot, the scripts hangs at the command

cd /opt/stack/cinder && /usr/local/bin/cinder-volume --config-file /etc/cinder/cinder.conf

with the message

2013-07-08 16:55:12.935 ERROR cinder.openstack.common.rpc.common   [req-94a7b477-794b-4679-864d-dd6deb7ba5e8 None None] AMQP server on localhost:5672 is  unreachable: Socket closed. Trying again in 1 seconds.
2013-07-08 16:55:13.939 INFO cinder.openstack.common.rpc.common [req-94a7b477-794b-4679-864d-dd6deb7ba5e8 None None] Reconnecting to AMQP server on localhost:5672
2013-07-08 16:55:14.006 DEBUG amqp [-] Start from server, version: 0.9, properties: {u'information': u'Licensed under the MPL.  See http://www.rabbitmq.com/', u'product': u'RabbitMQ', u'copyright': u'Copyright (C) 2007-2011 VMware, Inc.', u'capabilities': {u'exchange_exchange_bindings': True, u'consumer_cancel_notify': True, u'publisher_confirms': True, u'basic.nack': True}, u'platform': u'Erlang/OTP', u'version': u'2.7.1'}, mechanisms: [u'PLAIN', u'AMQPLAIN'], locales: [u'en_US'] from (pid=4554) _start /usr/local/lib/python2.7/dist-packages/amqp/connection.py:706

It is true that there is no one listening (at least on ipv4):

root@devstack:~# netstat -tulpen |grep 5672
tcp6       0      0 :::5672                 :::*                    LISTEN      104        9733        1285/beam.smp

What am I missing? What could I do to further debug this?

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
1

answered 2013-08-10 20:21:39 -0500

fifieldt gravatar image

OpenStack uses a AMQP messaging bus for various components to communicate. By default, this is provided by RabbitMQ, but on RedHat-based systems usually QPID is used.

What the error means, and as you've noted, is that the RabbitMQ/QPID server is not running. Check the logs to determine if it has failed to start for some reason (such as missing the 'rabbit_password' as noted by bvivek), or if there is nothing there try starting it manually using the appropriate init script.

Once RabbitMQ/QPID is started, you should be able to start cinder once again.

edit flag offensive delete link more
0

answered 2013-08-10 10:32:18 -0500

bvivek gravatar image

I had the same issue and it was solved by correcting the "rabbit_password" value in cinder.conf file.

For default installation this value is "guest" (please verify this in your setup).

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2013-07-08 10:06:19 -0500

Seen: 1,047 times

Last updated: Aug 10 '13