Ask Your Question
0

why would pip install fail of glance client? - icehouse (ubuntu14.04) [closed]

asked 2014-05-10 07:43:45 -0500

tarawa1943 gravatar image

All other PROJECTclient installed without a problem. Installing: Install fails and upgrade fails.

Any help appreciated. wm

:~# /usr/local/bin/pip install  python-glanceclientRequirement already satisfied (use --upgrade to upgrade): python-glanceclient in /usr/local/lib/python2.7/dist-packages

Requirement already satisfied (use --upgrade to upgrade): pbr>=0.5.21,<1.0 in /usr/local/lib/python2.7/dist-packages (from python-glanceclient) Requirement already satisfied (use --upgrade to upgrade): PrettyTable>=0.6,<0.8 in /usr/lib/python2.7/dist-packages (from python-glanceclient) Requirement already satisfied (use --upgrade to upgrade): python-keystoneclient>=0.3.0 in /usr/local/lib/python2.7/dist-packages (from python-glanceclient) Requirement already satisfied (use --upgrade to upgrade): pyOpenSSL in /usr/lib/python2.7/dist-packages (from python-glanceclient) Requirement already satisfied (use --upgrade to upgrade): warlock>=1.0.1,<2 in /usr/local/lib/python2.7/dist-packages (from python-glanceclient) Requirement already satisfied (use --upgrade to upgrade): pip in /usr/local/lib/python2.7/dist-packages (from pbr>=0.5.21,<1.0->python-glanceclient) Requirement already satisfied (use --upgrade to upgrade): Babel>=1.3 in /usr/lib/python2.7/dist-packages (from python-keystoneclient>=0.3.0->python-glanceclient) Requirement already satisfied (use --upgrade to upgrade): iso8601>=0.1.9 in /usr/lib/python2.7/dist-packages (from python-keystoneclient>=0.3.0->python-glanceclient) Requirement already satisfied (use --upgrade to upgrade): netaddr>=0.7.6 in /usr/local/lib/python2.7/dist-packages (from python-keystoneclient>=0.3.0->python-glanceclient) Requirement already satisfied (use --upgrade to upgrade): oslo.config>=1.2.0 in /usr/local/lib/python2.7/dist-packages (from python-keystoneclient>=0.3.0->python-glanceclient) Requirement already satisfied (use --upgrade to upgrade): requests>=1.1 in /usr/lib/python2.7/dist-packages (from python-keystoneclient>=0.3.0->python-glanceclient) Requirement already satisfied (use --upgrade to upgrade): six>=1.5.2 in /usr/local/lib/python2.7/dist-packages (from python-keystoneclient>=0.3.0->python-glanceclient) Requirement already satisfied (use --upgrade to upgrade): jsonschema>=0.7,<3 in /usr/lib/python2.7/dist-packages (from warlock>=1.0.1,<2->python-glanceclient) Requirement already satisfied (use --upgrade to upgrade): jsonpatch>=0.10,<2 in /usr/local/lib/python2.7/dist-packages (from warlock>=1.0.1,<2->python-glanceclient) Requirement already satisfied (use --upgrade to upgrade): pytz>=0a in /usr/local/lib/python2.7/dist-packages (from Babel>=1.3->python-keystoneclient>=0.3.0->python-glanceclient) Requirement already satisfied (use --upgrade to upgrade): jsonpointer>=1.3 in /usr/local/lib/python2.7/dist-packages (from jsonpatch>=0.10,<2->warlock>=1.0.1,<2->python-glanceclient) Cleaning up...

:~# /usr/local/bin/pip install --upgrade python-glanceclient Requirement already up-to-date: python-glanceclient in /usr/local/lib/python2.7/dist-packages Requirement already up-to-date: pbr>=0.5.21,<1.0 in /usr/local/lib/python2.7/dist-packages (from python-glanceclient) Requirement already up-to-date: PrettyTable>=0.6,<0.8 in /usr/lib/python2.7/dist-packages (from python-glanceclient) Requirement already up-to-date: python-keystoneclient>=0.3.0 in /usr/local/lib/python2.7/dist-packages (from python-glanceclient) Downloading/unpacking pyOpenSSL from https://pypi.python.org/packages/source/p/pyOpenSSL/pyOpenSSL-0.14.tar.gz#md5=8579ff3a1d858858acfba5f046a4ddf7 (https://pypi.python.org/packages/sour...) (from python-glanceclient) Downloading pyOpenSSL-0.14 ... (more)

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by tarawa1943
close date 2014-05-15 11:53:19.509730

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-05-15 11:52:44 -0500

tarawa1943 gravatar image

Solution apt-get install pythonPROJECTclient for all clients.

edit flag offensive delete link more

Comments

I don't know what pythonPROJECTclient is ?

Akalin gravatar imageAkalin ( 2015-01-05 08:31:09 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-05-10 07:43:45 -0500

Seen: 492 times

Last updated: May 15 '14