how to configure HA for quantum l3-agent [closed]

asked 2013-07-08 04:16:35 -0500

langqing2013 gravatar image

updated 2013-08-12 16:30:29 -0500

koolhead17 gravatar image

i have finished the use case for "Provider Router with Private Networks". But now i want to get my "Provider Router" to be more stable, so HA config needed.
i try the following steps, but failed:
1) find two host, and install and config l3-agent respectively
2) for each host, install and config pacemaker
3) get the l3-agent pacemaker script from
4) run command: crm configure primitive ClusterRouter1 ocf:openstack:quantum-l3-agent
and then, i get a fail message in /var/log/messages:

Jul  8 15:50:41 localhost quantum-agent-l3(ClusterRouter1)[10757]: ERROR: Quantum L3 Server is not connected to the Quantum server: 1

i found the reason is the network connection check in l3-agent pacemaker script:

network_amqp_check=`netstat -punt | grep -s "$OCF_RESKEY_quantum_server_port" | grep -s "$pid" | grep -qs "ESTABLISHED"`

the default value for OCF_RESKEY_quantum_server_port is 9696, the service port of quantum-server. but my l3-agent process has only connection to the AMQP service, so the error occurs. Plz tell me how to fix it?
My software version is openstack-quantum-2013.1-3.el6.noarch on rhel6.3

And furthermore, where to find the detail step for l3-agent HA configure?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by koolhead17
close date 2014-02-15 23:04:36.351459


That script is not part of OpenStack core. You might be able to get help from the author if you open an issue on the GitHub repo.

darragh-oreilly gravatar imagedarragh-oreilly ( 2013-07-10 02:53:33 -0500 )edit

Thanks for your advice. i modified the script and the error disappeared now.

langqing2013 gravatar imagelangqing2013 ( 2013-07-16 23:21:17 -0500 )edit

What were your modifications, and can you post them here for others to reference, please?

OldParrothead gravatar imageOldParrothead ( 2013-07-20 10:10:32 -0500 )edit