Ask Your Question
1

VMs not accessable using Floating-ip(Stderr: 'ovs-ofctl: -1: negative values not supported for in_port\n')

asked 2014-05-09 10:01:32 -0600

Veena gravatar image

Hi, I have 3 node setup with 1 node as controller+compute+network(neutron with ovs) other 2 are compute nodes. I'm not able to access the VMs using floatingIPs. There are errors in /var/log/neutron/metering-agent.log as Stderr: 'ovs-ofctl: -1: negative values not supported for in_port\n'

I have pasted the complete log in http://paste.openstack.org/show/79538/

I also referred to the links https://ask.openstack.org/en/question... https://ask.openstack.org/en/question... https://bugs.launchpad.net/neutron/+b...

And have followed the suggestions given in that. Have installed openvswitch-datapath-dkms. ovs-ofctl show br-tun lists the gre ports

OFPT_FEATURES_REPLY (xid=0x2): dpid:0000fe7ff229694f
n_tables:254, n_buffers:256
capabilities: FLOW_STATS TABLE_STATS PORT_STATS QUEUE_STATS ARP_MATCH_IP

actions: OUTPUT SET_VLAN_VID SET_VLAN_PCP STRIP_VLAN SET_DL_SRC SET_DL_DST SET_NW_SRC SET_NW_DST SET_NW_TOS SET_TP_SRC SET_TP_DST ENQUEUE
 1(patch-int): addr:5a:87:21:63:3c:59
     config:     0
     state:      0

     speed: 0 Mbps now, 0 Mbps max
 2(gre-2): addr:aa:e6:1e:e9:cc:55
     config:     0
     state:      0
     speed: 0 Mbps now, 0 Mbps max
 3(gre-3): addr:aa:2d:3e:18:ec:0e
     config:     0
     state:      0

     speed: 0 Mbps now, 0 Mbps max
 LOCAL(br-tun): addr:fe:7f:f2:29:69:4f
     config:     0
     state:      0
     speed: 0 Mbps now, 0 Mbps max
OFPT_GET_CONFIG_REPLY (xid=0x4): frags=normal miss_send_len=0

Openvswitch version is also correct. Modinfo openvswitch shows:

filename:       /lib/modules/3.8.0-38-generic/updates/dkms/openvswitch.ko
version:        1.10.2
license:        GPL
description:    Open vSwitch switching datapath

srcversion:     C57BFF12C03B30A057F0B4B
depends:
vermagic:       3.8.0-38-generic SMP mod_unload modversions.

Still I get the error of negative port in openvswitch-agent.log. Please guide me on how I can solve this issue.

Please suggest how to solve this issue.

Thanks,

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
1

answered 2014-09-29 23:24:15 -0600

tuna gravatar image

I see several posts related to this issue but noone replied. I'm facing the same issue. Has anyone resolved it?

edit flag offensive delete link more

Comments

Finally I found this post: http://bizzard2000.wordpress.com/2014/06/ (http://bizzard2000.wordpress.com/2014...)

Need to upgrade Centos kernel to support GRE tunneling. Issue closed!

Thanks Bizzard :-)

tuna gravatar imagetuna ( 2014-09-30 04:31:30 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-05-09 10:01:32 -0600

Seen: 302 times

Last updated: Sep 29 '14