Ask Your Question
0

OpenStack creating instance in KVM rather than VMware Vcenter 5.5

asked 2014-05-08 13:03:52 -0600

kamal gravatar image

Hi,

About my setup:

I have installed 1 openstack controller and 2 KVM compute nodes and 1 dedicated compute node for managing VMware vcenter server. (vCenter 5.5 manages two ESXi 5.5 hosts). Note: Using Openstack Havana and Ubuntu 12.04.4

am able to create instance in KVM compute nodes using openstack dashboard and the instance are working fine.

i recently integrated VMware vcenter 5.5 to openstack and am able to see VMware vcenter cluster details in openstack dashboard in the hypervisor tab Reference link used for integration: http://docs.openstack.org/havana/conf...

I also uploaded vmdk images to glance, which is also visible in openstack dashboard images tab

Issue:

When i deploy an instance using vmdk image from openstack dashboard the instance is getting deployed in KVM compute nodes rather than VMware vCenter cluster.

Please clarify how can i direct openstack dashboard to deploy the vmdk instance in VMware vcenter cluster?

Do i need to check any configuration settings in openstack components and VMware vcenter?

where do i need to check for any logs regarding this error?

Any help is much appreciated

edit retag flag offensive close merge delete

Comments

It might be usefull for you Can i install nova-compute in OpenStack Controller for managing VMware vSphere5.5
In particular it contains following (quote)

If you are using Neutron as networking technology you must have a plugin (basically NSX) that could work with both hypervisors in your infrastructure (KVM and ESXi). The alternative to use both is to switch to nova-network.
dbaxps gravatar imagedbaxps ( 2014-05-08 13:49:09 -0600 )edit

2 answers

Sort by ยป oldest newest most voted
2

answered 2015-03-19 18:49:14 -0600

jjulien gravatar image

You need to make sure the hypervisor_type property on the glance image is set to vmware. You will also need to set the vmware_disktype and vmware_adaptertype properties on the image.

http://docs.openstack.org/juno/config-reference/content/vmware.html#VMware_images

edit flag offensive delete link more
2

answered 2015-03-19 23:43:44 -0600

Jjulien is correct about setting hypervisor_type.

For glance images that you want on KVM:

Set hypervisor_type kvm.

For glance images that you want on vSphere :

Set hypervisor_type VMware.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-05-08 13:03:52 -0600

Seen: 377 times

Last updated: Mar 19 '15