Ask Your Question
0

Openstack installation problem

asked 2013-07-05 11:00:16 -0500

Deepak gravatar image

updated 2013-07-05 23:36:06 -0500

Jobin gravatar image

Hi,

I have been trying to install opensack in my VM for the past two weeks and till now it keeps giving me some error or the other. Today I am getting following error.

Please help me.

ERROR: HTTPConnectionPool(host='129.12.44.77', port=8774): Max retries exceeded with url: /v2/7660f8b42dd94fc2955a700e3a285149/flavors (Caused by <class 'socket.error'>: [Errno 111] Connection refused)
+ clean
+ local r=1
++ jobs -p
+ kill
edit retag flag offensive close merge delete

5 answers

Sort by ยป oldest newest most voted
0

answered 2013-07-05 11:27:48 -0500

Rajini gravatar image

updated 2013-07-05 14:11:27 -0500

May be not all stack services are not running. Check the services end-points using keystone command 'keystone endpoints-list' to see which service is running on port 8774. or you can run './rejoin-stack.sh' in the devstack folder

edit flag offensive delete link more
0

answered 2013-12-03 16:08:15 -0500

kesten gravatar image

updated 2013-12-03 16:11:29 -0500

I had the same error due to savanna.conf having host = 10.0.11.100

my ip address instead of localhost. When I commented out this line

# host = 10.0.11.100

It worked.

That's because a different interface is used (eth0 not loopback in my case) and the url is

echo $SAVANNA_URL

http://localhost:8386/v1.0/f51a9d1948db4940b21d362002761e66

as directed by the savanna quickstart guide.

To check this situation, try telnet localhost 8386 and telnet 10.0.11.100 # replacing with your ip

In my case, i could only connect to the ip not localhost, until I changed the config as mentioned above.

I believe you can either have all urls with your ip and host = ip or all urls localhost with host = localhost #by default or set explicitly

But you cannot mix the two.

edit flag offensive delete link more
0

answered 2013-07-06 00:23:37 -0500

This looks like a nova issue. Check the nova logs for more information on the error.

edit flag offensive delete link more
0

answered 2014-01-30 04:26:42 -0500

Suprith gravatar image

updated 2014-01-30 04:27:33 -0500

Restart the message server as: service rabbitmq-server restart and restart cinder services: service cinder-api restart service cinder-volume restart service cinder-scheduler-restart

It worked for me. Hope it helps..

edit flag offensive delete link more
0

answered 2014-01-18 00:04:45 -0500

ross-golder gravatar image

Also check your 'enabled_apis' value. For me, as I'd converted a controller node to a compute node, I'd forgotten to remove the 'enabled_apis=metadata' so the other two services were not being started where they were expected to be.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2013-07-05 11:00:16 -0500

Seen: 2,546 times

Last updated: Jan 30 '14