Ask Your Question
0

Using AWS Elastic IPs with Openstack

asked 2014-05-06 15:37:58 -0500

phil gravatar image

updated 2014-05-07 12:09:30 -0500

I'm trying to setup AWS Elastic IPs with Openstack, I had managed to get this to work but was forced to reboot and my changes didn't hold, I can't be that far off. The first time it worked I used this and this to solve my problems/guide me but they are no longer helping.

What issue am I facing? When I associate an elastic ip with a private ip on amazon, it doesn't "bridge" that gap. From the controller I can ping floating ip addresses I assign to the private network (using my Openstack controller), but I can't ping Amazon elastic IPs pointing to Amazon/Openstack floating IPs.

My network is setup like this, my second NIC has an ip of 10.0.136.112 so I assigned secondary private IPs (10.0.136.113 through .118 for exapmple) through amazon to its private IP address. In Openstack I took that pool I created and used it for my floating IPs.

To illustrate, 54.85.85.85 (Amazon Elastic IP) points to 10.0.136.116 ( Amazon private IP / Openstack floating IP) points to 192.168.0.5 (IP assigned on Openstack private ip).

So pinging 10.0.136.116 from the controller works, and all my instances do have internet connectivity. What doesn't work is attempting to ping 54.85.85.85 from another compute. Not sure what I'm doing wrong at this point, I've been staring at this for too long so any advice is appreciated.

Thanks for reading!

edit: I've started over from scratch but selected a range of ips that doesn't share a range with either eth0 or eth1 and I'm getting the same result.

Network Map

ip a output

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 9001 qdisc pfifo_fast state UP qlen 1000
    link/ether 0a:9c:15:f8:b3:59 brd ff:ff:ff:ff:ff:ff
    inet 10.0.0.167/16 brd 10.0.255.255 scope global eth0
    inet6 fe80::89c:15ff:fef8:b359/64 scope link 
       valid_lft forever preferred_lft forever
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 0a:9a:e0:f8:3c:6b brd ff:ff:ff:ff:ff:ff
    inet 10.0.136.112/32 scope global eth1
    inet6 fe80::89a:e0ff:fef8:3c6b/64 scope link 
       valid_lft forever preferred_lft forever
4: ovs-system: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN 
    link/ether 36:a1:c0:ae:4e:b6 brd ff:ff:ff:ff:ff:ff
5: br-ex: <BROADCAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN 
    link/ether 42:16:bb:3a:7f:4d brd ff:ff:ff:ff:ff:ff
    inet 10 ...
(more)
edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
1

answered 2014-05-16 04:21:26 -0500

SGPJ gravatar image

I am not sure you cannot have Elastic IP in Openstack.

edit flag offensive delete link more
0

answered 2016-12-29 04:21:43 -0500

Vinoth gravatar image

https://ask.openstack.org/en/question...

Any kind of help would be greatly appreciated!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-05-06 15:37:58 -0500

Seen: 470 times

Last updated: Dec 29 '16