Ask Your Question
3

Account HEAD failed: http://controller:8080:8080/v1/AUTH_c84481ebd46b48509f102a76540ce965 503 Internal Server Error

asked 2014-05-06 03:07:19 -0500

Livenux Chou gravatar image

[root@controller ~]# swift -V 2 -A http://controller:5000/v2.0 -U service:swift -K swift stat

Account HEAD failed: http://controller:8080:8080/v1/AUTH_c84481ebd46b48509f102a76540ce965 503 Internal Server Error

[root@controller ~]# keystone endpoint-list | grep 8080

| 5eaa1f8e5b1247b28d7625bde991c9d5 | regionOne | http://controller:8080/v1/AUTH_%(tenant_id)s | http://controller:8080/v1/AUTH_%(tenant_id)s |          http://controller:8080         | 61be2dfbc3104e6ab11b5d61eef86555 |

swift proxy-server.conf: [root@controller ~]# cat /etc/swift/proxy-server.conf

[DEFAULT]
bind_port = 8080
user = swift

[pipeline:main]
pipeline = healthcheck cache authtoken keystoneauth proxy-server

[app:proxy-server]
use = egg:swift#proxy
allow_account_management = true
account_autocreate = true

[filter:keystoneauth]
use = egg:swift#keystoneauth
operator_roles = Member,admin,swiftoperator

[filter:authtoken]
paste.filter_factory = keystoneclient.middleware.auth_token:filter_factory

# Delaying the auth decision is required to support token-less
# usage for anonymous referrers ('.r:*').
delay_auth_decision = true

# cache directory for signing certificate
signing_dir = /etc/swift/keystone-signing

# auth_* settings refer to the Keystone server
auth_protocol = http
auth_host = controller
auth_port = 35357

# the service tenant and swift username and password created in Keystone
admin_tenant_name = service
admin_user = swift
admin_password = swift

[filter:cache]
use = egg:swift#memcache

[filter:catch_errors]
use = egg:swift#catch_errors

[filter:healthcheck]
use = egg:swift#healthcheck

cat /var/log/message

May  6 15:53:44 controller proxy-server: ERROR with Account server 192.168.11.231:6002/sda4 re: Trying to HEAD /v1/AUTH_c84481ebd46b48509f102a76540ce965: Connection refused (txn: tx0ff02ba674aa454c8e2b7-0053689508) (client_ip: 192.168.11.251)
May  6 15:53:44 controller proxy-server: Account HEAD returning 503 for [] (txn: tx0ff02ba674aa454c8e2b7-0053689508) (client_ip: 192.168.11.251)
May  6 15:53:46 controller proxy-server: ERROR with Account server 192.168.11.232:6002/sda4 re: Trying to HEAD /v1/AUTH_c84481ebd46b48509f102a76540ce965: Connection refused (txn: txf4d9af8b2eed458ab9dbd-005368950a) (client_ip: 192.168.11.251)
May  6 15:53:46 controller proxy-server: ERROR with Account server 192.168.11.231:6002/sda4 re: Trying to HEAD /v1/AUTH_c84481ebd46b48509f102a76540ce965: Connection refused (txn: txf4d9af8b2eed458ab9dbd-005368950a) (client_ip: 192.168.11.251)
May  6 15:53:46 controller proxy-server: Account HEAD returning 503 for [] (txn: txf4d9af8b2eed458ab9dbd-005368950a) (client_ip: 192.168.11.251)
May  6 15:53:50 controller proxy-server: ERROR with Account server 192.168.11.232:6002/sda4 re: Trying to HEAD /v1/AUTH_c84481ebd46b48509f102a76540ce965: Connection refused (txn: tx2138315142864c039107f-005368950e) (client_ip: 192.168.11.251)
May  6 15:53:50 controller proxy-server: ERROR with Account server 192.168.11.231:6002/sda4 re: Trying to HEAD /v1/AUTH_c84481ebd46b48509f102a76540ce965: Connection refused (txn: tx2138315142864c039107f-005368950e) (client_ip: 192.168.11.251)
May  6 15:53:50 controller proxy-server: Account HEAD returning 503 for [] (txn: tx2138315142864c039107f-005368950e) (client_ip: 192.168.11.251)
May  6 15:53:58 controller proxy-server: ERROR with Account server 192.168.11.232:6002/sda4 re: Trying to HEAD /v1/AUTH_c84481ebd46b48509f102a76540ce965: Connection refused (txn: tx933f75694fd14c93a6369-0053689516) (client_ip: 192.168.11.251)
May  6 15:53:58 controller proxy-server: ERROR with Account server 192.168.11.231:6002/sda4 re: Trying to HEAD /v1/AUTH_c84481ebd46b48509f102a76540ce965: Connection refused (txn: tx933f75694fd14c93a6369-0053689516) (client_ip: 192.168.11.251)
May  6 15:53:58 controller proxy-server: Account HEAD returning 503 for [] (txn: tx933f75694fd14c93a6369-0053689516) (client_ip: 192.168.11.251)
May  6 15:54:14 controller proxy-server: ERROR with Account server 192.168.11.231:6002 ...
(more)
edit retag flag offensive close merge delete

Comments

1

Hi

Check with the URL http://controller:8080:8080/

there seems proxy port configured and requested two times.

It should be like that http://controller:8080:/v1/AUTH_c8448...

himanshu gravatar imagehimanshu ( 2014-05-08 06:34:33 -0500 )edit

How to check it? I've been troubleshooting, they say install this problem does not occur using rdo, I use Yum to install on centos 6.5

Livenux Chou gravatar imageLivenux Chou ( 2014-05-08 20:08:36 -0500 )edit

3 answers

Sort by » oldest newest most voted
1

answered 2014-05-16 07:24:21 -0500

ih8mondays gravatar image

On your host controller, check its IP address. For example if the IP address of controller is 192.168.1.123, do:

openstack-config --set /etc/swift/account-server.conf DEFAULT bind_ip 192.168.1.123

Or you can have it bind to all available interfaces and IP addresses by doing:

openstack-config --set /etc/swift/account-server.conf DEFAULT bind_ip 0.0.0.0

Once you done that, do:

swift-init all restart

You can also bind container-server and object-server to your controller IP address by doing the following commands:

openstack-config --set /etc/swift/container-server.conf DEFAULT bind_ip 192.168.1.123
openstack-config --set /etc/swift/object-server.conf DEFAULT bind_ip 192.168.1.123

Or you can bind to all interfaces and IP addresses:

openstack-config --set /etc/swift/container-server.conf DEFAULT bind_ip 0.0.0.0
openstack-config --set /etc/swift/object-server.conf DEFAULT bind_ip 0.0.0.0

However if you are just doing a single-node install, it should be enough to bind account-server to the correct IP address. Just make sure you run swift-init to restart all services after making these changes to your configuration.

edit flag offensive delete link more
0

answered 2014-05-08 08:10:26 -0500

Cuold it be the same problem (account-server config) solved in question ?

edit flag offensive delete link more

Comments

account-server.conf is not matter,question is the http://controller:8080:8080 -> double 8080.where is it from?

Livenux Chou gravatar imageLivenux Chou ( 2014-05-08 20:01:46 -0500 )edit

yes! exactly i am facing same problem! would any one please help to guide that what is the source point of this error http://controller:8080:8080

hpetwal gravatar imagehpetwal ( 2015-04-25 00:33:47 -0500 )edit
0

answered 2014-05-13 02:01:34 -0500

Rex gravatar image

updated 2014-05-13 02:02:56 -0500

openstack-config --set /etc/swift/object-server.conf DEFAULT bind_ip store_server_ip openstack-config --set /etc/swift/account-server.conf DEFAULT bind_ip store_server_ip openstack-config --set /etc/swift/container-server.conf DEFAULT bind_ip store_server_ip

and /etc/swift/swift.conf

[swift-hash] swift_hash_path_suffix = xxxxxxxxxx

all server must same

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-05-06 03:07:19 -0500

Seen: 17,501 times

Last updated: May 16 '14