unable to ping/ssh instance [closed]

asked 2014-05-05 09:52:10 -0600

anonymous user

Anonymous

Hi,

i am implementing 2 node openstack havana on ubuntu 12.04(1 controller+network,1 compute) i am using 2 interfaces eth0 & eth1. eth0 for host management & eth1 for bridging & vm access. both ports are on same subnet 10.126.58.0/24. i am using neutron L2 agent for networking. i am able to ping to/from instance to/from controller node.but unable to ping the external gateway or compute or other nodes on the same subnet instances are getting ip from dhcp on controller node

please help me to resolve this issue. let me know if you need any other details.

ping between the instances are working. but unable to ping the gateway 10.126.58.254 or any other hosts which are on the same subnet

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by sudarshan
close date 2014-05-06 03:19:22.023348

Comments

Could you ping your gateway from the virtual networking entity on your network node?

# ip netns
   networking-entity-ID

# ip netns exec <networking-entity-ID> ping 10.126.58.254
Antonio G. gravatar imageAntonio G. ( 2014-05-05 09:57:47 -0600 )edit

root@heos-ctrls:~# ip netns exec qdhcp-bfdd989c-bf99-4996-8699-6a3bd01ad618 ping 10.126.58.254 PING 10.126.58.254 (10.126.58.254) 56(84) bytes of data. From 10.126.58.41 icmp_seq=1 Destination Host Unreachable From 10.126.58.41 icmp_seq=2 Destination Host Unreachable From 10.126.58.41 icmp_seq=3 Destination Host Unreachable

also i found 1 more thing, i.e i am unable to ping the gateway from the controller as well.

as i said earlier i am using 2 nics with ip of same subnet with same gateway. if i delete default gw route i am able to ping instance but if i add the gw route i am unable to ping the instance but able to ping the gateway.

sudarshan gravatar imagesudarshan ( 2014-05-06 01:44:40 -0600 )edit
1

Hi Antonio

Thanks for your help. Issue is resolved . eth1 cable was connected to the switch which was not connected to the gateway. i connected eth1 to correct switch & now i am able to ping gateway & vm at the same time.

sudarshan gravatar imagesudarshan ( 2014-05-06 03:18:47 -0600 )edit