Ask Your Question
1

keystone not working after upgrade to grizzly

asked 2013-07-04 04:06:50 -0600

bnight gravatar image

Hi all,

On ubuntu 12.04 I upgrade my keystone to Grizzly and the keystone-manage db_sync failed. Could someone let me know what are the main difference in Keystone SQL db between Folsom and Grizzly. I really want to get this working. Currently I could get auth token but this auth token is not working with nova list for example gives me that I`m not authorized to use the service.

Please help me.

edit retag flag offensive close merge delete

Comments

Hope you did not make any changes to your environment variables like OS_USERNAME, OS_PASSWORD, OS_TENANT_NAME, OS_AUTH_URL, etc. and yes see if this bug affects you.

Jobin gravatar imageJobin ( 2013-07-04 04:12:15 -0600 )edit

I didnt change any of my environment variables. However I suppose something is wrong with my roles and groups as its not working as expected about the token format I set this in keystone.conf: default_format = UUID but didnt change anything still Im not authorized.

bnight gravatar imagebnight ( 2013-07-04 04:19:09 -0600 )edit

The error that I get after db sync is here: https://bugs.launchpad.net/keystone/+bug/1197367 And also I did setup PKI however change the default_fromat = UUID and still I didn`t get authorization as expected.

bnight gravatar imagebnight ( 2013-07-05 08:36:14 -0600 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-07-29 20:40:34 -0600

fifieldt gravatar image

For complex debugging of upgrade issues, you should probably post on the openstack-operators mailing list ( http://lists.openstack.org ), or join the #openstack channel on IRC ( http://wiki.openstack.org/IRC ).

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2013-07-04 04:06:50 -0600

Seen: 149 times

Last updated: Jul 29 '14