Ask Your Question
0

Router interfaces are not up physically and in database

asked 2014-05-02 02:01:52 -0500

lokesh gravatar image

updated 2014-05-02 04:28:41 -0500

I have setup a multinode Openstack setup behind proxy in my organization. The deployment model looks like this:

Version: Havana on all ubuntu 12.04 OS.

  1. Controller node (vm) - 2 ethX
  2. Neutron Node (vm) - 3 ethX
  3. Cinder Service Node (vm) 2 ethX
  4. Compute Node Physical 2 ethX

Everything works fine till I create a vm in it which gets active. However the vms are not accessible and eventually when I looked into logs and tried accessing neutron node it wasn't accessible. And after I got inside neutron via vnc and checked logs even neutron was not able to access Controller node.

Some exceptions which I did against what was given in upgrade guide are: I'm using the same ips for internal and external network for all nodes. It's not external but private vlan of my organization. Base network which I created was having external network with ips of my org's vlan. And internal vlan for a tenant. And a router which connects both of these.

PS: I'm not able to post pics of ifconfig, ovs-vsctl show and interfaces as I don't have 10 points to post a pic. Will try to get text out somehow.

ifconfig:

root@lksh-quantum:/tmp# cat ifconfig
br-ex     Link encap:Ethernet  HWaddr 7e:e1:ee:28:ee:42
          inet6 addr: fe80::acf9:81ff:fe33:b015/64 Scope:Link
          UP BROADCAST RUNNING  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:468 (468.0 B)

br-int    Link encap:Ethernet  HWaddr ea:c3:40:d6:f4:4e
          inet6 addr: fe80::a44f:55ff:fedd:ba6a/64 Scope:Link
          UP BROADCAST RUNNING  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:468 (468.0 B)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:1128 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1128 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:90736 (90.7 KB)  TX bytes:90736 (90.7 KB)

ovs-vsctl show:

45be40e1-2c17-470f-bd32-f260a453edfd
    Bridge br-ex
        Port br-ex
            Interface br-ex
                type: internal
        Port "eth2"
            Interface "eth2"
    Bridge br-int
        Port br-int
            Interface br-int
                type: internal
    ovs_version: "1.10.2"

interfaces:
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
        address 10.44.64.57
        netmask 255.255.252.0
        gateway 10.44.64.1
        dns-nameservers 10.44.224.100 10.44.224.198

auto eth1
iface eth1 inet static
        address 10.44.64.58
        netmask 255.255.252.0
        gateway 10.44.64.1
        dns-nameservers 10.44.224.100 10.44.224.198 ...
(more)
edit retag flag offensive close merge delete

Comments

I did a little tweak and found that at least the vms are able to talk to each other on internal network.

Following is the way I changed the interface.However what I'm surprised about is by using ovs-vsctl as well we patched eth2 to br-ex but unless I explicity did that in interface it didn't work.

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
        address 10.44.64.57
        netmask 255.255.252.0
        gateway 10.44.64.1
        dns-nameservers 10.44.224.100 10.44.224.198

auto eth1
iface eth1 inet static
        address 10.44.64.58
        netmask 255.255.252.0
        gateway 10.44.64.1
        dns-nameservers 10.44.224.100 10.44.224.198

auto eth2
iface eth2 inet manual

auto br-ex
iface br-ex inet static
        address 10.44.64.65
        netmask 255.255.252.0
        gateway 10.44 ...
(more)
lokesh gravatar imagelokesh ( 2014-05-02 03:30:25 -0500 )edit

Had reached one more level ahead..

root@lksh-quantum:~# neutron router-port-list --column id --column status --column fixed_ips 8d749164-0e92-4974-aebb-7a9df47b0858
+--------------------------------------+--------+------------------------------------------------------------------------------------+
| id                                   | status | fixed_ips                                                                          |
+--------------------------------------+--------+------------------------------------------------------------------------------------+
| 3dfb6fb4-0262-4b3b-a82c-58e275f56bef | DOWN   | {"subnet_id": "39bda355-b740-493c-8d5e-dd2e147d376f", "ip_address": "10.5.5.1"}    |
| bb904c8a-16c3-4f3d-bd12-07a70d939037 | DOWN   | {"subnet_id": "76ad5bd2-ff6b-48c7-8924-8910c5b408e0", "ip_address": "10.44.64.67"} |
+--------------------------------------+--------+------------------------------------------------------------------------------------+

However now the problem is how to bring these interfaces up? Both internal and external once cannot be pinged.

lokesh gravatar imagelokesh ( 2014-05-02 04:19:08 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-05-02 06:03:33 -0500

lokesh gravatar image

updated 2014-05-02 06:36:52 -0500

Found this in logs

Router id is required if not using namespaces.

And after that one of the interfaces came up and I can ping 10.5.5.1 as well. After a little while even the external one came up and everything is tip top!!

I realized I cannot close the question. So I request the moderators to do that.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-05-02 02:01:52 -0500

Seen: 188 times

Last updated: May 02 '14