Ask Your Question
0

compute node default network configuration

asked 2014-05-01 10:48:27 -0500

leonardo gravatar image

Hello all,

I am setting up an openstack cloud with legacy nova network. I have the following setup,

1) Controller (1 NIC card with the follwing network configuration)

auto lo
iface lo inet loopback

iface eth0 inet static
address 192.168.30.2
network 192.168.30.0
netmask 255.255.255.0
broadcast 192.168.30.255
gateway 192.168.30.1

2) On the compute node, I have two NICs (eth0 and eth1)

auto lo
iface lo inet loopback

iface eth0 inet static
address 192.168.30.3
network 192.168.30.0
netmask 255.255.255.0
broadcast 192.168.30.255
gateway 192.168.30.1

Question; I got several errors while trying to launch an instance. The errors happening after trying to set the gateway on the VM and the readable error is "Device not found". I am guessing that it is due to the fact that I have not setup the bridge. Can anyone guide me that how the network configuration should look like after the bridge has been setup. Below is my relevant nova network config;

network_manager=nova.network.manager.FlatDHCPManager
network_size = 254
allow_same_net_traffic = False
multi_host = True
send_arp_for_ha = True
share_dhcp_address = True
force_dhcp_release = True
flat_network_bridge = br100
flat_interface = eth1
public_interface = eth1

I will appreciate the help.

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
0

answered 2014-05-01 12:49:38 -0500

fifieldt gravatar image

The bridge will be automatically created.

It looks like you are missing the configuration to bring eth1 up.

See http://docs.openstack.org/trunk/insta...

edit flag offensive delete link more
0

answered 2014-05-01 12:59:55 -0500

leonardo gravatar image

updated 2014-05-01 13:34:56 -0500

HI fifeldt,

Thanks for your answer. The interface configuration should look like this on both nodes then;

Controller

auto lo
iface lo inet loopback
auto eth0
iface eth0 inet static
address 192.168.30.2
network 192.168.30.0
netmask 255.255.255.0
broadcast 192.168.30.255
gateway 192.168.30.1

Compute Node

auto lo
iface lo inet loopback
auto eth0
iface eth0 inet static
address 192.168.30.3
network 192.168.30.0
netmask 255.255.255.0
broadcast 192.168.30.255
gateway 192.168.30.1

auto eth1
iface eth1 inet manual
up ip link set dev eth1 up
down ip link set dev eth1 down

Correct?

edit flag offensive delete link more

Comments

on the compute node. As you say, your controller only has one nic :)

fifieldt gravatar imagefifieldt ( 2014-05-01 13:22:15 -0500 )edit

my compute node has two NICs and the controller has one NIC. :) Plus, I hope OpenStack does not complain that I SHOULD have two NICs on the controller....

leonardo gravatar imageleonardo ( 2014-05-01 13:31:53 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-05-01 10:48:27 -0500

Seen: 153 times

Last updated: May 01 '14