Ask Your Question
1

What is meant by "configure the hypervisor to permit promiscuous mode on the external network" as mentioned in the Docs for installing Icehouse on 3-Node setup

asked 2014-05-01 01:19:07 -0500

screwgoth gravatar image

I am trying to install Icehousr on a 3-Node setup with Ubuntu 14.04 on Virtual Machines. However, I'm not able to get my Networking right. I am able to ping all the 3 nodes on the Management network and even get a instance running with internal as well as external IP assigned , as seen on the Horizon dashboard. But I'm not able to ping the instance either from Host or either of the 2 nodes. I doubt that I may have setup my VM networking incorrectly. In the docs it is mentioned that : "If you are building your OpenStack nodes as virtual machines, you must configure the hypervisor to permit promiscuous mode on the external network." What does this mean ?

edit retag flag offensive close merge delete

Comments

I'm also doing the same as @screwgoth and @jmhal. The dialogue until this point suggests that the fix is to apply promiscuous mode on the physical host but the instructions explicitly state that the hypervisor must enable it as well. Just want to confirm configuring the physical host is enough.

TheFutonEng gravatar imageTheFutonEng ( 2014-09-11 15:13:40 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
4

answered 2014-05-01 07:43:15 -0500

capsali gravatar image

If you are running the 3 nodes in VM's than the ethernet from the network node that is responsible for the external network must work in promiscuous mode. On phisycal hardware, all new network adapters have this feature. But in a virtualized envoirament, u must tell the hypervisor to enable promiscuous mode on that ethernet adapter. Promiscuous mode means that all packages will be received by that ethernet. In normal mode, if a package is not meant for that ethernet it will be droped, and accept only packages ment for that interface. In promiscuous mode all packages are received.

edit flag offensive delete link more

Comments

Basically if the NIC doesn't own the MAC address then the traffic is dropped. Since the network node will be accepting traffic for many different MAC addresses that it doesn't own on a physical NIC you'll have to turn promisc on so that it allows the traffic instead of dropping it.

mpetason gravatar imagempetason ( 2014-05-01 10:17:09 -0500 )edit

How to configure hypervisor to permit promiscuous mode ? I am using libvirt/KVM/QEMU.Thanks in advance.

boez gravatar imageboez ( 2014-06-25 03:37:03 -0500 )edit

It is done at the base OS, so you would be turning it on for the interfaces such as eth0/eth1/eth2.

http://www.kernelfaq.com/2008/04/enab...

mpetason gravatar imagempetason ( 2014-06-25 09:59:09 -0500 )edit

I'm doing the same setup as @screwgoth. On my virtualized network node, the external interface is eth2. So, to tell the KVM hypervisor to enable promiscuous mode, a simple

:~# ifconfig eth2 promisc

is enough?

jmhal gravatar imagejmhal ( 2014-07-21 13:32:09 -0500 )edit

I'm also doing the same as @screwgoth and @jmhal. The dialogue until this point suggests that the fix is to apply promiscuous mode on the physical host but the instructions explicitly state that the hypervisor must enable it as well. Just want to confirm configuring the physical host is enough.

TheFutonEng gravatar imageTheFutonEng ( 2014-09-11 09:33:08 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2014-05-01 01:19:07 -0500

Seen: 6,110 times

Last updated: May 01 '14