Ask Your Question
0

glance image-create returns invalid credentials [closed]

asked 2014-04-30 10:01:51 -0500

danoreilly gravatar image

updated 2014-04-30 10:12:09 -0500

SamYaple gravatar image
# glance image-create --name=cirros-0.3.2-x86_64-disk --disk-format=qcow --container-format=bare --is-public=TRUE < /data/glance/temp_images/cirros-0.3.2-x86_64-disk.img     
Request returned failure status.
Invalid OpenStack Identity credentials.

I'm lost here. Been trying to figure this out for a couple days. My configuration:

# keystone tenant-list
+----------------------------------+---------+---------+
|                id                |   name  | enabled |
+----------------------------------+---------+---------+
| 8c8d3dd9eb004beaaf7ea3c8678f2225 |  admin  |   True  |
| 5b48acd0c85a4e73849e2855c51064e8 |   demo  |   True  |
| 475ce6d4f52f44799fed764a0a7ccbe7 | service |   True  |
+----------------------------------+---------+---------+

# keystone user-list
+----------------------------------+--------+---------+----------------------+
|                id                |  name  | enabled |        email         |
+----------------------------------+--------+---------+----------------------+
| f9e00dccc9b94f8abde602eeb2c8c5bc | admin  |   True  | dan.oreilly@dish.com |
| 2f0d90f28b754d94a440c85dd733022b |  demo  |   True  | dan.oreilly@dish.com |
| 80bc3aca2d544432b0ff97cdab29eb9f | glance |   True  | dan.oreilly@dish.com |
+----------------------------------+--------+---------+----------------------+
# keystone service-list
+----------------------------------+----------+----------+-------------------------+
|                id                |   name   |   type   |       description       |
+----------------------------------+----------+----------+-------------------------+
| d2e13af1386b443da196d13c827ae584 |  glance  |  image   | OpenStack Image Service |
| c4d4536c729a4b489ca1112987af85e5 | keystone | identity |    OpenStack Identity   |
+----------------------------------+----------+----------+-------------------------+
# set | grep OS_
OS_AUTH_URL=http://tm1cldctll01:35357/v2.0
OS_PASSWORD=xxxxxxxxxxxxx
OS_TENANT_NAME=admin
OS_USERNAME=admin

help!!!!!

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by danoreilly
close date 2014-06-06 21:31:17.982046

Comments

Can you examine your keystone logs at the same time. You should be able to identify what is breaking with that. You may also try running your glance command with --debug to get some extra info (though in this case I believe your issue is with keystone).

Do you have multiple nodes setup, or is this all on one controller node?

SamYaple gravatar imageSamYaple ( 2014-04-30 10:15:10 -0500 )edit

Do you have any ERROR line in your glance log files? If so pastebin them.

Could you pastebin your glance config files?

Did you follow any guide to install Openstack on your infrastructure? Which OpenStack release are you using?

Antonio G. gravatar imageAntonio G. ( 2014-04-30 10:20:23 -0500 )edit

Antonio - yes, I'm faithfully following the Openstack docs at http://docs.openstack.org . I'm using the latest & greatest for RHEL 6.5.

danoreilly gravatar imagedanoreilly ( 2014-04-30 10:24:49 -0500 )edit

I modified the command line to include --os-password and --os-username, and it changed the message to be: The request you have made requires authentication. (HTTP 401)

danoreilly gravatar imagedanoreilly ( 2014-04-30 10:27:23 -0500 )edit

I get the same response with things like glance image-list.

danoreilly gravatar imagedanoreilly ( 2014-04-30 10:34:31 -0500 )edit

3 answers

Sort by ยป oldest newest most voted
2

answered 2014-06-05 19:36:37 -0500

jame gravatar image

For me I had to drop the Keystone user entry for glance and then recreate it and it's role and this fixed it. I suspect I did set the password wrong the first time, perhaps left the instruction manual password in there. Here's the commands I had to issue;

keystone user-list # to get the id

keystone user-delete cbadb6fff68a4165a09ba9db75cc850d

keystone user-create --name=glance --pass=password --email=me@gmail.com

keystone user-role-add --user=glance --tenant=service --role=admin

edit flag offensive delete link more
1

answered 2014-04-30 10:29:21 -0500

mpetason gravatar image

Are you able to glance image-list or any of the other glance commands? Have you setup the keystone auth information within the glance configuration files? Glance should be aware of the "glance" user and auth information within the conf files for it. Maybe turn on debug in glance/keystone too.

edit flag offensive delete link more
0

answered 2014-04-30 10:23:40 -0500

danoreilly gravatar image

updated 2014-05-01 12:03:48 -0500

SUCCESS!!!!!

Turned out I had a minor substitution error in a script that was causing the problem. All is well.

I genuinely appreciate all the suggestions and willingness to help from all of you!

edit flag offensive delete link more

Comments

That means you have a wrong username/password somewhere. Check your configs for glance. It should have your "service" tenant glance credentials

SamYaple gravatar imageSamYaple ( 2014-04-30 10:41:06 -0500 )edit

I blew away glance and installed everything new. Now I get this in the log file:

2014-04-30 10:07:39.266 6399 WARNING glance.store.base [-] Failed to configure store correctly: Store gridfs could not be configured correctly. Reason: Missing dependencies: pymongo Disabling add method. 2014-04-30 10:07:39.266 6399 WARNING glance.store [-] Deprecated: glance.store.gridfs.Store not found in known_store. Stores need to be explicitly enabled in the configuration file. 2014-04-30 10:07:39.293 6399 WARNING glance.store.base [-] Failed to configure store correctly: Store cinder could not be configured correctly. Reason: Cinder storage requires a context. Disabling add method. 2014-04-30 10:07:39.293 6399 WARNING glance.store [-] Deprecated: glance.store.cinder.Store not found in known_store. Stores need to be explicitly enabled in the configuration file. 2014-04-30 10:07:39.299 6399 ERROR glance.store.swift [-] Could not find swift_store_auth_address in configuration options. 2014-04-30 ...(more)

danoreilly gravatar imagedanoreilly ( 2014-04-30 11:09:06 -0500 )edit

You set the appropriate credentials in the glance-api.conf and glance-registry.conf files?

SamYaple gravatar imageSamYaple ( 2014-04-30 12:19:51 -0500 )edit

I'm assuming you aren't using swift since keystone doesn't have a swift endpoint. If that's the case then you can ignore the swift errors, it just means you don't have swift setup in the conf. You are more than likely using "file" as the store, which should use the defaults for the storage location.

mpetason gravatar imagempetason ( 2014-04-30 13:21:11 -0500 )edit

I had this problem and it turned out I had not changed my password to the correct value in the glance-registry.conf for the line: connection = mysql://glance:password@controller/glance

jame gravatar imagejame ( 2014-06-04 22:48:18 -0500 )edit

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-04-30 10:01:51 -0500

Seen: 7,120 times

Last updated: Jun 05 '14