Ask Your Question
1

OpenStack icehouse on a fresh installation of Fedora 20

asked 2014-04-30 09:21:55 -0500

arindamchoudhury gravatar image

Hi,

On a fresh Fedora 20, I want to install Openstack icehouse allinone.

So I followed the quickstart:

  1. sudo yum install -y http://rdo.fedorapeople.org/rdo-relea...
  2. sudo yum install -y openstack-packstack
  3. packstack --allinone

which gives me this error:

ERROR : Error appeared during Puppet run: 158.109.65.21_amqp.pp

Error: rpm --import http://www.rabbitmq.com/rabbitmq-sign... returned 1 instead of one of [0]

in amqp.pp.log:

Warning: Config file /etc/puppet/hiera.yaml not found, using Hiera defaults Notice: Compiled catalog for HOSTNAME in environment production in 1.31 seconds Notice: /Stage[main]/Rabbitmq::Repo::Rhel/Exec[rpm --import http://www.rabbitmq.com/rabbitmq-sign... : curl: (6) Could not resolve host: www.rabbitmq.com Notice: /Stage[main]/Rabbitmq::Repo::Rhel/Exec[rpm --import http://www.rabbitmq.com/rabbitmq-sign... : error: http://www.rabbitmq.com/rabbitmq-sign... : import read failed(2). Error: rpm --import http://www.rabbitmq.com/rabbitmq-sign... returned 1 instead of one of [0] Error: /Stage[main]/Rabbitmq::Repo::Rhel/Exec[rpm --import http://www.rabbitmq.com/rabbitmq-sign... : change from notrun to 0 failed: rpm --import http://www.rabbitmq.com/rabbitmq-sign... returned 1 instead of one of [0] Notice: /Stage[main]/Main/Enable_rabbitmq[rabbitmq]/Package[erlang]/ensure: created Notice: /Stage[main]/Rabbitmq::Install/Package[rabbitmq-server]: Dependency Exec[rpm --import http://www.rabbitmq.com/rabbitmq-sign... has failures: true Warning: /Stage[main]/Rabbitmq::Install/Package[rabbitmq-server]: Skipping because of failed dependencies Notice: /Stage[main]/Rabbitmq::Config/File[/etc/rabbitmq]: Dependency Exec[rpm --import http://www.rabbitmq.com/rabbitmq-sign... has failures: true Warning: /Stage[main]/Rabbitmq::Config/File[/etc/rabbitmq]: Skipping because of failed dependencies Notice: /Stage[main]/Rabbitmq::Config/File[rabbitmq.config]: Dependency Exec[rpm --import http://www.rabbitmq.com/rabbitmq-sign... has failures: true Warning: /Stage[main]/Rabbitmq::Config/File[rabbitmq.config]: Skipping because of failed dependencies Notice: /Stage[main]/Rabbitmq::Config/File[/etc/rabbitmq/ssl]: Dependency Exec[rpm --import http://www.rabbitmq.com/rabbitmq-sign... has failures: true Warning: /Stage[main]/Rabbitmq::Config/File[/etc/rabbitmq/ssl]: Skipping because of failed dependencies Notice: /Stage[main]/Rabbitmq::Config/File[rabbitmq-env.config]: Dependency Exec[rpm --import http://www.rabbitmq.com/rabbitmq-sign... has failures: true Warning: /Stage[main]/Rabbitmq::Config/File[rabbitmq-env.config]: Skipping because of failed dependencies Notice: /Stage[main]/Rabbitmq::Service/Service[rabbitmq-server]: Dependency Exec[rpm --import http://www.rabbitmq.com/rabbitmq-sign... has failures: true Warning: /Stage[main]/Rabbitmq::Service/Service[rabbitmq-server]: Skipping because of failed dependencies Notice: /Stage[main]/Rabbitmq/Anchor[rabbitmq::end]: Dependency Exec[rpm --import http://www.rabbitmq.com/rabbitmq-sign... has failures: true Warning: /Stage[main]/Rabbitmq/Anchor[rabbitmq::end]: Skipping because of failed dependencies Notice: /Stage[main]/Main/Packstack::Firewall[amqp_]/Firewall[001 amqp incoming amqp_]/ensure: created Notice: Finished catalog run in 210.40 seconds

Any help will be highly appreciated.

Thanks,

edit retag flag offensive close merge delete

Comments

In home dir should be answer-file generated during failed setup. I would analyze it to switch to QPIDD from RABBITMQ. At least Havana AIO ( and multi node setup) works with QPIDD.

dbaxps gravatar imagedbaxps ( 2014-04-30 10:42:01 -0500 )edit
1

Done just now on F20 KVM during IceHouse RDO AIO install :-

Installing Dependencies                              [ DONE ]
Copying Puppet modules and manifests                 [ DONE ]
Applying 192.168.122.137_prescript.pp
192.168.122.137_prescript.pp:                        [ DONE ]           
Applying 192.168.122.137_mysql.pp
Applying 192.168.122.137_amqp.pp
192.168.122.137_mysql.pp:                            [ DONE ]       
192.168.122.137_amqp.pp:                             [ DONE ]       
Applying 192.168.122.137_keystone.pp
Applying 192.168.122.137_glance.pp
Applying 192.168.122.137_cinder.pp
192.168.122.137_keystone.pp:                         [ DONE ]
dbaxps gravatar imagedbaxps ( 2014-05-01 03:49:13 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
0

answered 2014-05-01 19:40:01 -0500

cstachris gravatar image

updated 2014-05-01 19:41:43 -0500

*Mentioned here http://www.mrvoip.com.au/blog/openstack-fedora-20-install-workaround-after-vim-erlang-fail

From a fresh install of fed 20

yum remove vim-minimal

yum install erlang

then continue as normal.*

edit flag offensive delete link more

Comments

Per menrioned link

Then continue with the RDO Quickstart stuff from RedHat
yum install -y http: // rdo.fedorapeople.org/rdo-release.rpm
yum install -y openstack-packstack
packstack --allinone

It's about Havana not IceHouse.
dbaxps gravatar imagedbaxps ( 2014-05-01 20:33:54 -0500 )edit

Re the vim-minimal thing, see https://bugzilla.redhat.com/1066983 Perhaps the more general fix it to run yum update before proceeding, which will ensure all installed components are up to date.

pixelbeat gravatar imagepixelbeat ( 2014-05-02 03:06:19 -0500 )edit
-1

answered 2014-05-01 03:56:03 -0500

dbaxps gravatar image

updated 2014-05-01 03:57:23 -0500

You have issue with Internet access ( been behind corporate firewall or so) or your own DNS is not tuned due to message :-

Could not resolve host: www.rabbitmq.com Notice: /Stage[main]/Rabbitmq::Repo::Rhel/Exec[rpm --import http://www.rabbitmq.com/rabbitmq-sign... : error: http://www.rabbitmq.com/rabbitmq-sign... : import read failed(2). Error: rpm --import http://www.rabbitmq.com/rabbitmq-sign... returned 1 instead of one of [0]
edit flag offensive delete link more

Comments

In meantime AIO IceHouse KVM (@F20 KVM Server) is completly functional and runing Cirros and F20 instances ( nested KVM) with Internet access. Due to update from pixelbeat : add to neutron.conf

nova_url = http://<IP>:8774/v2
nova_admin_username = admin
nova_admin_tenant_id = <admin tenant id>
nova_admin_password = <admin password>
nova_admin_auth_url = http://<IP>:5000/v2.0/
dbaxps gravatar imagedbaxps ( 2014-05-01 10:17:35 -0500 )edit

And one more update to neutron.conf (Assaf Muller)
agent_down_time = 75
report_interval=30

dbaxps gravatar imagedbaxps ( 2014-05-01 11:40:32 -0500 )edit

Just to confirm that the currently released packstack (1055) and openstack-puppet-modules-2014.1-0.9 do the above nova/neutron config automatically

pixelbeat gravatar imagepixelbeat ( 2014-05-02 03:08:06 -0500 )edit

Just one notice. How to manage behind firewall ? Request to open special port .....
See http://xmodulo.com/2013/07/how-to-install-rpm-packages-behind-proxy.html. If it won't work this way, then should be a way it will work. @pixelbeat Thanks for the update.

DanIzack gravatar imageDanIzack ( 2014-05-02 03:16:46 -0500 )edit

You can setup a proxy at the yum level like: http://openstack.redhat.com/forum/dis...

Also if you need to setup proxy env variables for general external HTTP access, you might need to adjust openstack settings to avoid the proxy for internal openstack services: https://ask.openstack.org/en/question...

pixelbeat gravatar imagepixelbeat ( 2014-05-02 04:45:53 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-04-30 09:21:55 -0500

Seen: 1,421 times

Last updated: May 01 '14