Ask Your Question
2

Unable to load quantum from configuration file /etc/neutron/api-paste.ini - Icehouse

asked 2014-04-30 06:50:05 -0500

anonymous user

Anonymous

updated 2014-05-03 14:07:06 -0500

Hello, Im trying to setup a 3-node architecture with Controller, compute and network on separate nodes (virtual machines, ubuntu server 12.04).

Controller, and compute are working fine, Glance, Nova, and Image services are all working fine on these 2 nodes. Im trying to configure the network node and encountered this problem when I run the command neutron-server:

raise RuntimeError(msg)
"ERROR: Unable to load quantum from configuration file /etc/neutron/api-paste.ini"

The neutron files seems ok, I just dont know what to do. This is the api-paste.ini file, note that authtoken does not have some configuration. I tried with and without auth_host, auth_protocol, etc etc. Still did not work. I'm using Icehouse.

Edit:

Also checked if the neutron python files would contain any wrongful information regarding the "app_name=" but it seems its also neutron there, not quantum. So it really confuses me why its trying to load quantum when the new name is neutron.

edit retag flag offensive close merge delete

Comments

On the controller node, running the command "neutron-server", I assume this command is to start the services.

rubicon ( 2014-04-30 09:26:34 -0500 )edit

Ok, are you following this guide or another one?

So does the error raise when you run:

service neutron-server restart

?

Antonio G. ( 2014-04-30 09:34:24 -0500 )edit

Precisely, im following that documentation, it feels like it misses some steps, and yeah, error raise when I run that command aswell.

rubicon ( 2014-04-30 10:25:27 -0500 )edit

Edit the question to add more details, don't engage in hard to follow conversations as 'comments'.

smaffulli ( 2014-05-02 16:06:16 -0500 )edit

I'm getting the same error on CentOS 6.5 with RDO running a neutron provider plugin (midonet). My api_paste.ini only contains the [filter:authtoken] section.

Tim ( 2014-07-18 16:33:02 -0500 )edit

6 answers

Sort by ยป oldest newest most voted
0

answered 2014-05-02 22:24:46 -0500

dbaxps gravatar image

I beilive you api-paste.ini is missing entries like :-

admin_user=neutron
auth_port=35357
admin_password=xxxxxxxx
auth_protocol=http
auth_uri=http://192.168.1.127:5000/
admin_tenant_name=services
auth_host = 192.168.1.127
edit flag offensive delete link more

Comments

As described in my post, I wrote that I have tried using those specific credentials in my api-paste.ini file, to no effect unfortunetely.

rubicon ( 2014-05-03 14:01:39 -0500 )edit
0

answered 2015-05-22 02:03:03 -0500

junneyang gravatar image

how this problem be solved? i have stuck in this problem too. thank you

edit flag offensive delete link more
0

answered 2014-06-18 00:41:35 -0500

Yang Yu gravatar image

I also confused with this problem. But I use ipdb to debug the process of startup, I found that the problem is caused by the wrong configuration of service plugin, not the api-paste.ini

edit flag offensive delete link more

Comments

Could you post ml2_plugin.ini , plugin.ini (OVS) ?

dbaxps ( 2014-06-18 01:16:35 -0500 )edit
0

answered 2014-07-24 05:12:45 -0500

damon.wang gravatar image

Hi, I have meet this problem too, the solution is use rabbit instead of zeromq.

If you check log more carefully, I think you'll find why.

edit flag offensive delete link more
0

answered 2014-08-07 08:39:06 -0500

If neutron fails to load the configuration using the 'neutron' app_name, it tries using the old quantum app_name. You'll find the following message in the log Error occurred: trying old api-paste.ini

You need to check the messages prior to that one to find the real causes of the failure.

edit flag offensive delete link more
0

answered 2014-10-13 20:52:58 -0500

Hi. I think I'm facing a similar issue:

When I try to restart neutron using the following command:

python /usr/local/bin/neutron-server --config-file /etc/neutron/neutron.conf --config-file /etc/neutron/plugins/ml2/ml2_conf.ini --config-file /etc/neutron/plugins/ml2/ml2_conf_arista.ini || echo "q-svc failed to start" | tee "/opt/stack/status/stack/q-svc.failure"

I get the following:

2014-10-13 18:46:27.968 75293 DEBUG neutron.service [req-664293e0-25c7-4de3-aef2-e93a062f11e3 None] keystone_authtoken.signing_dir = /var/cache/neutron log_opt_values /usr/local/lib/python2.7/dist-packages/oslo/config/cfg.py:2000
2014-10-13 18:46:27.968 75293 DEBUG neutron.service [req-664293e0-25c7-4de3-aef2-e93a062f11e3 None] keystone_authtoken.token_cache_time = 300 log_opt_values /usr/local/lib/python2.7/dist-packages/oslo/config/cfg.py:2000
2014-10-13 18:46:27.969 75293 DEBUG neutron.service [req-664293e0-25c7-4de3-aef2-e93a062f11e3 None] ml2_type_gre.tunnel_id_ranges  = ['1:1000'] log_opt_values /usr/local/lib/python2.7/dist-packages/oslo/config/cfg.py:2000
2014-10-13 18:46:27.969 75293 DEBUG neutron.service [req-664293e0-25c7-4de3-aef2-e93a062f11e3 None] ******************************************************************************** log_opt_values /usr/local/lib/python2.7/dist-packages/oslo/config/cfg.py:2002
2014-10-13 18:46:27.970 75293 INFO neutron.common.config [req-664293e0-25c7-4de3-aef2-e93a062f11e3 None] Config paste file: /etc/neutron/api-paste.ini
2014-10-13 18:46:27.971 75293 ERROR neutron.common.config [req-664293e0-25c7-4de3-aef2-e93a062f11e3 None] Unable to load quantum from configuration file /etc/neutron/api-paste.ini.
2014-10-13 18:46:27.971 75293 TRACE neutron.common.config Traceback (most recent call last):
2014-10-13 18:46:27.971 75293 TRACE neutron.common.config   File "/opt/stack/neutron/neutron/common/config.py", line 170, in load_paste_app
2014-10-13 18:46:27.971 75293 TRACE neutron.common.config     app = deploy.loadapp("config:%s" % config_path, name=app_name)
2014-10-13 18:46:27.971 75293 TRACE neutron.common.config   File "/usr/lib/python2.7/dist-packages/paste/deploy/loadwsgi.py", line 247, in loadapp
2014-10-13 18:46:27.971 75293 TRACE neutron.common.config     return loadobj(APP, uri, name=name, **kw)
2014-10-13 18:46:27.971 75293 TRACE neutron.common.config   File "/usr/lib/python2.7/dist-packages/paste/deploy/loadwsgi.py", line 271, in loadobj
2014-10-13 18:46:27.971 75293 TRACE neutron.common.config     global_conf=global_conf)
2014-10-13 18:46:27.971 75293 TRACE neutron.common.config   File "/usr/lib/python2.7/dist-packages/paste/deploy/loadwsgi.py", line 296, in loadcontext
2014-10-13 18:46:27.971 75293 TRACE neutron.common.config     global_conf=global_conf)
2014-10-13 18:46:27.971 75293 TRACE neutron.common.config   File "/usr/lib/python2.7/dist-packages/paste/deploy/loadwsgi.py", line 320, in _loadconfig
2014-10-13 18:46:27.971 75293 TRACE neutron.common.config     return loader.get_context(object_type, name, global_conf)
2014-10-13 18:46:27.971 75293 TRACE neutron.common.config   File "/usr/lib/python2.7/dist-packages/paste/deploy/loadwsgi.py", line 408, in get_context
2014-10-13 18:46:27.971 75293 TRACE neutron.common.config     object_type, name=name)
2014-10-13 18:46:27.971 75293 TRACE neutron.common.config   File "/usr/lib/python2.7/dist-packages/paste/deploy/loadwsgi.py", line 587, in find_config_section
2014-10-13 18:46:27.971 75293 TRACE neutron.common.config     self.filename))
2014-10-13 18:46:27.971 75293 TRACE neutron.common.config LookupError: No section 'quantum ...
(more)
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

[hide preview]

Get to know Ask OpenStack

Resources for moderators

Question Tools

Follow
1 follower

Stats

Asked: 2014-04-30 06:50:05 -0500

Seen: 3,156 times

Last updated: May 22