Ask Your Question
1

packstack installation ends up with neutron agent intermittently on and off. [closed]

asked 2014-04-30 05:04:20 -0500

anonymous user

Anonymous

Hi, I'm installing OpenStack Icehouse with packstack to CentOS 6.5 or 6.4 (all-in-one)

Installing itself finishes with no error, but neuron-server intermittently fails to connect with neutron agents.
I checked with "neutron agent-list" and I found that neutron agents becomes online around 4-5 seconds every about 30 seconds, and becomes offline again.

There's no error in neutron log, neutron agents logs or rabbitmq log. Does anyone experiencing similar problem?

Thank you.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by t.goto
close date 2014-05-25 20:22:34.733296

Comments

1

Can you paste the neutron.conf on all nodes? Specifically looking for agent_down_time on the controller node, and report_interval on the compute nodes. Just a hunch: But you might want to increase the agent_down_time and/or decrease the agent report_interval.

Assaf Muller gravatar imageAssaf Muller ( 2014-05-01 02:56:46 -0500 )edit

Same issue after AIO IceHouse setup on F20. Failure to launch instance due to the virtual interface creation failure

dbaxps gravatar imagedbaxps ( 2014-05-01 06:10:07 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
2

answered 2014-05-01 06:16:47 -0500

updated 2014-05-01 06:17:05 -0500

We're fixing this up now. As a workaround please add this to nova.conf on the compute node:

 vif_plugging_is_fatal: false
 vif_plugging_timeout value: 0

p.s. This workaround is listed on the RDO icehouse quick start guide

edit flag offensive delete link more

Comments

packstack-2014.1...1055 and openstack-puppet-modules-2014.1-9 now in the RDO repos should address this issue

pixelbeat gravatar imagepixelbeat ( 2014-05-01 07:05:37 -0500 )edit

I've updated nova.conf & restarted AIO IceHouse VM.
openstack-status is fine
ip netns list & neutron net-list& neutron router-list matches fine
& neutron agent-list is fine
Attempt to launch Cirros guest takes a while and gives same results. No luck
.

dbaxps gravatar imagedbaxps ( 2014-05-01 08:21:21 -0500 )edit

you could try to edit the config, that the updated puppet modules are now actually doing. I.E. add the following in /etc/neutron/neutron.conf

nova_url = http://<IP>:8774/v2
nova_admin_username = admin
nova_admin_tenant_id = <admin tenant id>
nova_admin_password = <admin password>
nova_admin_auth_url = http://<IP>:5000/v2.0/
pixelbeat gravatar imagepixelbeat ( 2014-05-01 09:15:37 -0500 )edit

The last update to neutron.conf fixed problem. Thank you very much.

dbaxps gravatar imagedbaxps ( 2014-05-01 10:08:26 -0500 )edit
0

answered 2014-05-01 05:02:04 -0500

t.goto gravatar image

Thanks for info, Mr.Muller.

Looks like you hit the gold :) Below were the original intervals from neutron.conf

agent_down_time = 9
report_interval=4

I changed those options to default, and neutron agents looks online again.

agent_down_time = 75
report_interval=30

Still, I cannot create instances due to the virtual interface creation failure, but I guess it is separate issue. One step forward, thank you!

edit flag offensive delete link more

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2014-04-30 05:04:20 -0500

Seen: 378 times

Last updated: May 01 '14