Ask Your Question
2

You should rebuild using libgmp >= 5 to avoid timing attack vulnerability. _warn("Not using mpz_powm_sec. You should rebuild using libgmp >= 5 to avoid timing attack vulnerability.", PowmInsecureWarning)

asked 2014-04-29 03:45:08 -0500

Livenux Chou gravatar image

I install openstack icehouse on centos 6.5,Cinder is installed in the Control node, and synchronize mysql databases, the following error occurred: su -s /bin/sh -c "cinder-manage db sync" cinder /usr/lib64/python2.6/site-packages/Crypto/Util/number.py:57: PowmInsecureWarning: Not using mpz_powm_sec. You should rebuild using libgmp >= 5 to avoid timing attack vulnerability. _warn("Not using mpz_powm_sec. You should rebuild using libgmp >= 5 to avoid timing attack vulnerability.", PowmInsecureWarning)

i try to remove amp-4,But too much depend on the package, and Deleting I'm done openstack environment。 shell> rpm -qa | grep gmp gmp-4.3.1-7.el6_2.2.x86_64 shell>yum list gmp gmp.x86_64 4.3.1-7.el6_2.2 @anaconda-CentOS-201311272149.x86_64/6.5 Available Packages gmp.i686 4.3.1-7.el6_2.2 base shell>yum remove gmp ...... : selinux-policy-targeted-3.7.19-231.el6_5.1.noarch --> Running transaction check ---> Package selinux-policy-targeted.noarch 0:3.7.19-231.el6_5.1 will be erased --> Finished Dependency Resolution Error: Trying to remove "yum", which is protected You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodigest

edit retag flag offensive close merge delete

Comments

I have the same issue, followed the documentation to the letter & encountered the same error.

Dan gravatar imageDan ( 2014-05-02 05:04:19 -0500 )edit

Hi I got the same issue after installing openstack by using RDO packstack. if anybody can help

dev gravatar imagedev ( 2014-05-07 16:00:49 -0500 )edit

6 answers

Sort by » oldest newest most voted
3

answered 2014-05-26 06:23:58 -0500

lupulcelbun gravatar image

Currently rhel has GMP version 4.something
PyCrypto needs GMP >= 5

Because rhel is slightly behind we have to re-make The GNU Multiple Precision Arithmetic Library stuff.
For this we have to download the sources from https://gmplib.org/#DOWNLOAD

According to the instructions from the package:
tar -xvjpf gmp-6.0.0a.tar.bz2
./configure
make
make check <= VERY IMPORTANT!!
make install


With the right libraries we rebuild PyCrypto
pip install --ignore-installed PyCrypto


As a side note, whenever building and re-building do a
yum -y groupinstall "Development tools"
yum -y install gcc libgcc glibc libffi-devel libxml2-devel libxslt-devel openssl-devel zlib-devel bzip2-devel ncurses-devel

It will take care of many problems you might encounter due to missing compilers and header files.

edit flag offensive delete link more

Comments

Can you please include:

yum -y install python-devel

In your answer? This was necessary for the final pip command to execute successfully under CentOS 6.6.

Locane gravatar imageLocane ( 2015-04-22 21:16:05 -0500 )edit
0

answered 2016-02-26 02:01:09 -0500

tomcate gravatar image

try once. I install openstack-icehouse, when add a tenant ,prompt this message.

edit flag offensive delete link more
0

answered 2014-11-21 10:28:23 -0500

mrbriancollins gravatar image

centos 6.6 going through openstack icehouse install guide. Found similar issue in glance install. Generated the errors above. Followed the config, compile and install process. Now results in these errors:

[root@stack1 gmp-6.0.0]# su -s /bin/sh -c "glance-manage db_sync" glance Traceback (most recent call last): File "/usr/bin/glance-manage", line 6, in <module> from glance.cmd.manage import main File "/usr/lib/python2.6/site-packages/glance/cmd/manage.py", line 45, in <module> from glance.db import migration as db_migration File "/usr/lib/python2.6/site-packages/glance/db/__init__.py", line 21, in <module> from glance.common import crypt File "/usr/lib/python2.6/site-packages/glance/common/crypt.py", line 23, in <module> from Crypto.Cipher import AES File "/usr/lib64/python2.6/site-packages/Crypto/Cipher/AES.py", line 50, in <module> from Crypto.Cipher import _AES ImportError: /usr/lib64/python2.6/site-packages/Crypto/Cipher/_AES.so: undefined symbol: rpl_malloc [root@stack1 gmp-6.0.0]#

edit flag offensive delete link more
0

answered 2014-12-07 23:25:47 -0500

if the issue is with Glance DB then try this.

Drop the glance database and set the character set to utf8 mysql -u root -e "CREATE DATABASE glance DEFAULT CHARACTER SET utf8";

edit flag offensive delete link more
0

answered 2015-02-01 20:58:23 -0500

pip install --ignore-installed PyCrypto

RuntimeError: autoconf error

----------------------------------------
Command "/usr/bin/python -c "import setuptools, tokenize;__file__='/tmp/pip-build-_8e620/PyCrypto/setup.py';exec(compile(getattr(tokenize, 'open', open)(__file__).read().replace('\r\n', '\n'), __file__, 'exec'))" install --record /tmp/pip-Hmslic-record/install-record.txt --single-version-externally-managed --compile" failed with error code 1 in /tmp/pip-build-_8e620/PyCrypto
edit flag offensive delete link more

Comments

I'm having this same problem. Is there some kind of resolution available?

Locane gravatar imageLocane ( 2015-04-22 21:13:00 -0500 )edit

I'm not allowed to post links yet, but I found a question on Stack Overflow that answered it - I needed the python development libraries.

yum -y install python-devel

Locane gravatar imageLocane ( 2015-04-22 21:15:34 -0500 )edit
0

answered 2015-04-22 21:33:57 -0500

Locane gravatar image

updated 2015-04-22 21:34:21 -0500

I ended up having to do several things, following lupulcelbun 's advice.

First, I had to install the development libraries:

yum -y groupinstall "Development tools" 
yum -y install gcc libgcc glibc libffi-devel libxml2-devel libxslt-devel openssl-devel zlib-devel bzip2-devel ncurses-devel python-devel

Next, I had to install the newest (at time of this writing) version of GMP:

wget https://ftp.gnu.org/gnu/gmp/gmp-6.0.0a.tar.bz2
tar -xvjpf gmp-6.0.0a.tar.bz2
cd gmp-6.0.0
./configure 
make 
make check
make install

Next, I had to uninstall the current (at time of this writing) version of PyCrypto

pip uninstall PyCrypto

And download a newer version directly from the them:

wget https://ftp.dlitz.net/pub/dlitz/crypto/pycrypto/pycrypto-2.6.1.tar.gz
tar -zxvf pycrypto-2.6.1.tar.gz
cd pycrypto-2.6.1
./configure
python setup.py install

And then I was able to run the db_sync command for Glance from the documentation.

edit flag offensive delete link more

Comments

Worked for me!

But I installed using

pip install PyCrypto
tiagocruz gravatar imagetiagocruz ( 2015-08-03 12:39:41 -0500 )edit

[root@Controller openstack]# [root@Controller openstack]# pip install PyCrypto DEPRECATION: Python 2.6 is no longer supported by the Python core team, please upgrade your Python. A future version of pip will drop support for Python 2.6 Requirement already satisfied (use --upgrade to upgrade): PyCry

tomcate gravatar imagetomcate ( 2016-03-01 21:05:30 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

4 followers

Stats

Asked: 2014-04-29 03:45:08 -0500

Seen: 22,939 times

Last updated: Feb 26 '16