Ask Your Question
0

failed to bind port neutron

asked 2014-04-28 16:58:46 -0500

granadol gravatar image

updated 2014-04-29 02:17:24 -0500

I have a 3 node Icehouse infrastructure (Controller,network,compute) running on Ubuntu 14.04. I have configured per instructions. When I try to start an instance, I get this is the server.log

2014-04-28 17:40:36.235 3123 WARNING neutron.plugins.ml2.managers [req-98f8f30f-0379-40a7-a2d5-67e94335f405 None] Failed to bind port bc63e9cf-1749-4c0b-8e6$
2014-04-28 17:40:36.714 3123 WARNING neutron.plugins.ml2.managers [req-98f8f30f-0379-40a7-a2d5-67e94335f405 None] Failed to bind port bc63e9cf-1749-4c0b-8e6$
$14 requested by agent ovs6edff4098749 on network 8c939d3a-e6cb-4ba1-8004-5444eb193f04 not bound, vif_type: binding_failed

Nothing in the openvswitch-agent.log

ovs-vsctl looks like this on network

Bridge br-int
        Port "tapbc63e9cf-17"
            tag: 4095
            Interface "tapbc63e9cf-17"
                type: internal
        Port patch-tun
            Interface patch-tun
                type: patch
                options: {peer=patch-int}
        Port br-int
            Interface br-int
                type: internal
        Port "qr-21ea5266-65"
            tag: 4095
            Interface "qr-21ea5266-65"
                type: internal
    Bridge br-tun
        Port br-tun
            Interface br-tun
                type: internal
        Port patch-int
            Interface patch-int
                type: patch
                options: {peer=patch-tun}
        Port "gre-ac1e0019"
            Interface "gre-ac1e0019"
                type: gre
                options: {in_key=flow, local_ip="172.30.0.40", out_key=flow, remote_ip="172.30.0.25"}
    Bridge br-ex
        Port "qg-d349ea60-eb"
            Interface "qg-d349ea60-eb"
                type: internal
        Port br-ex
            Interface br-ex
                type: internal
        Port "eth1"
            Interface "eth1"
    ovs_version: "2.0.1"

Any ideas?

edit retag flag offensive close merge delete

Comments

1

Are you sure there is nothing in the ovs agent log? What does sudo ovs-vsctl get interface tapbc63e9cf-17 ofport give?

darragh-oreilly gravatar imagedarragh-oreilly ( 2014-04-29 02:41:20 -0500 )edit
  1. Will try answer below
granadol gravatar imagegranadol ( 2014-04-29 17:35:46 -0500 )edit

2 answers

Sort by ยป oldest newest most voted
1

answered 2014-07-14 17:13:43 -0500

updated 2014-07-14 17:14:37 -0500

@caraboga, @Roberto Cano Fernandez, @Chris: check out FuzzyDog's solution in this thread [Error: Unexpected vif_type=binding_failed]. I don't know if you are facing the same issue, but that solution worked for me

edit flag offensive delete link more
0

answered 2014-04-30 08:44:29 -0500

granadol gravatar image

This is closed. I found an error in my code. Thank you everyone for the help.

edit flag offensive delete link more

Comments

1

Can you tell me what your mistake was? I'm having the same issue and I've been at this for about a week.

caraboga gravatar imagecaraboga ( 2014-06-02 23:51:04 -0500 )edit
1

Please, do explain what mistake you had, so that others may learn from it.

gkeller2 gravatar imagegkeller2 ( 2014-06-11 14:00:20 -0500 )edit

I'm having the same issue and I would like to know what's the solution for you.

Roberto Cano Fernandez gravatar imageRoberto Cano Fernandez ( 2014-06-16 09:16:08 -0500 )edit

Yeah, I ran into a similar error and would like to know your solution, too.

Chris gravatar imageChris ( 2014-06-24 18:08:22 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-04-28 16:58:46 -0500

Seen: 7,568 times

Last updated: Apr 30 '14