Ask Your Question
4

cloud-init-nonet waiting and fails

asked 2014-04-28 13:08:31 -0600

Diplomat gravatar image

Hey!

I have a strange problem.. when I'm booting ubuntu, then it fails like that:

 * Starting configure network device[74G[ OK ]
 * Stopping cold plug devices[74G[ OK ]
 * Stopping log initial device creation[74G[ OK ]
 * Starting load fallback graphics devices[74G[ OK ]
 * Starting load fallback graphics devices[74G[[31mfail[39;49m]
 * Starting enable remaining boot-time encrypted block devices[74G[ OK ]
Cloud-init v. 0.7.5 running 'init-local' at Mon, 28 Apr 2014 17:32:54 +0000. Up 4.27 seconds.
cloud-init-nonet[4.54]: waiting 10 seconds for network device
cloud-init-nonet[14.57]: waiting 120 seconds for network device
cloud-init-nonet[134.57]: gave up waiting for a network device.
Cloud-init v. 0.7.5 running 'init' at Mon, 28 Apr 2014 17:35:04 +0000. Up 134.67 seconds.
ci-info: +++++++++++++++++++++++Net device info+++++++++++++++++++++++
ci-info: +--------+------+-----------+-----------+-------------------+
ci-info: | Device |  Up  |  Address  |    Mask   |     Hw-Address    |
ci-info: +--------+------+-----------+-----------+-------------------+
ci-info: |   lo   | True | 127.0.0.1 | 255.0.0.0 |         .         |
ci-info: |  eth0  | True |     .     |     .     | fa:16:3e:92:6b:0f |
ci-info: +--------+------+-----------+-----------+-------------------+
ci-info: !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!Route info failed!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Any ideas what might be the problem? I have Googled everything, but no results

edit retag flag offensive close merge delete

3 answers

Sort by ยป oldest newest most voted
3

answered 2014-05-02 13:30:28 -0600

dmsimard gravatar image

updated 2014-05-02 14:43:33 -0600

Have you found a solution ? Found the problem, read my edit below.

I'm also trying to get 14.04 working with Cloud-init v0.7.5. I'm having the same problem.

If I boot 20 VMs with the same 14.04 image, maybe half of them will not ping and I get that error message in the console logs.

What I've found is that soft rebooting the VM will make it ping again.

I also logged to the VM in console, did a "ifdown eth0 && ifup eth0" and the VM started pinging.

Still investigating...

Edit: Found the problem.

I am not using DHCP networks in Openstack, instead relying on Neutron to provide an available address that cloud-init configures when the VM boots.

I use Ubuntu's cloud images ( http://cloud-images.ubuntu.com/trusty/current/ (http://cloud-images.ubuntu.com/trusty...) ).

What I learned is that the layout of the interfaces have changed. Instead of just /etc/network/interfaces, you now also have /etc/network/interfaces.d/<interface>.

Now, provided in the image, there is a /etc/network/interfaces.d/eth0 in which you'll find it configured for DHCP:

# The primary network interface
auto eth0
iface eth0 inet dhcp

When cloud-init starts doing it's stuff, it will configure eth0 inside /etc/network/interfaces - as such:

# Injected by Nova on instance boot
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
        address 172.27.58.189
        netmask 255.255.252.0
        broadcast 172.27.59.255
        gateway 172.27.56.1
        dns-nameservers 172.16.131.34

This means you'll end up with two eth0 interfaces configured if the one in interfaces.d is not removed - therefore explaining why 50-60% of my VMs were not pinging, probably running into a race condition.

I filed a bug against cloud-init: https://bugs.launchpad.net/cloud-init/+bug/1315501 (https://bugs.launchpad.net/cloud-init...)

edit flag offensive delete link more

Comments

I can't log into the instance to delete, is another work around from compute node or neutron server?

bobyakov gravatar imagebobyakov ( 2015-04-21 10:02:15 -0600 )edit
0

answered 2017-06-13 02:59:42 -0600

A similar problem cropped up with VirtualBox and ubuntu/trusty32 installed with vagrant. In this case, the problem was an unsupported ethernet card and switching VirtualBox to use a different adapter type fixed the problem. See, for example, https://github.com/adaptlearning/adapt_authoring/commit/574de9ef77abfa6b9d82e97305c4d94f56a45e1d (https://github.com/adaptlearning/adap...)

edit flag offensive delete link more
0

answered 2016-01-10 09:38:46 -0600

This works for me: https://github.com/mitchellh/vagrant/issues/391#issuecomment-2078383

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2014-04-28 13:08:31 -0600

Seen: 21,184 times

Last updated: May 02 '14