Ask Your Question
1

router interfaces are down

asked 2014-04-28 11:22:44 -0500

anonymous user

Anonymous

I am using 2 nodes (1 for compute & the other for control+neutron) using gre

able to ping internal ip of the instance & router gateway along with namespace of router from the controller. but cant ping without namespace.

topolopy show both interfaces of the router as down. Instance able to get the dhcp ip from he controller.

ovs-vsctl show da8a9ab0-d127-48b7-b2b5-02c02f416388 Bridge br-ex Port "eth2" Interface "eth2" Port br-ex Interface br-ex type: internal Bridge br-tun Port br-tun Interface br-tun type: internal Port "gre-2" Interface "gre-2" type: gre options: {in_key=flow, local_ip="192.168.10.3", out_key=flow, remote_ip="192.168.10.5"} Port patch-int Interface patch-int type: patch options: {peer=patch-tun} Bridge br-int Port br-int Interface br-int type: internal Port patch-tun Interface patch-tun type: patch options: {peer=patch-int} ovs_version: "1.10.2"

what would be the issue

edit retag flag offensive close merge delete

Comments

  1. Please , format you output
  2. Can you assign and ping floating IP of instance ?
  3. Routers interface to private network shoud be ACTIVE
  4. Can you ping floating IP within routers namespace ?
dbaxps gravatar imagedbaxps ( 2014-04-28 11:38:28 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-04-28 13:29:45 -0500

sudarshan gravatar image

To answer to your questions 2. i can assign floating ip to the instance, but unable to ping that ip. 3. Router interface to private network is not active. 4. i can ping floating ip within router namespace.

instance are able to recieve the pricvate ip from the dhcp. ping to private ip without namespace also doesnt work.

edit flag offensive delete link more

Comments

Due to your answers 2,4 routing from qdhcp namespace to qrouters namespace is a problem. I am running Two Node Neutron OVS&GRE clusters on F20 since 01/2014 pretty stable. Check one more time

[root@dfw02 ~(keystone_admin)]$ neutron router-port-list router5
+--------------------------------------+------+-------------------+--------------------------------------------------------------------------------------+
| id                                   | name | mac_address       | fixed_ips                                                                            |
+--------------------------------------+------+-------------------+--------------------------------------------------------------------------------------+
| 52247b0b-d9c5-4602-a134-9e97a4049d62 |      | fa:16:3e:c8:4b:56 | {"subnet_id": "caca1f54-3211-4395-ba3c-a0c26d9605c0", "ip_address": "10.0.0.5"}      |
| edd58124-4347-4450-9427-efb85f008804 |      | fa:16:3e:c4:14:08 | {"subnet_id": "f30e5a16-a055-4388-a6ea-91ee142efc3d", "ip_address": "192.168.1.107"} |
+--------------------------------------+------+-------------------+--------------------------------------------------------------------------------------+
[root@dfw02 ~(keystone_admin)]$ neutron port-show 52247b0b-d9c5-4602-a134-9e97a4049d62
dbaxps gravatar imagedbaxps ( 2014-04-28 21:57:25 -0500 )edit

If it won't show ACTIVE. It is first problem ( and maybe the last). Create another tenant, user for tenant . Create router, private net, connect this subnet to the router by setting it as a port. Check again.
You wrote :instance are able to recieve the private ip from the dhcp. ping to private ip without namespace also doesnt work.
. Answer , it's normal only within namespace.

dbaxps gravatar imagedbaxps ( 2014-04-28 22:11:29 -0500 )edit

Thanks for the reply. I created new tenant with new router & internal n/w. still the internal n/w port on the router shows down. I created new instance. instance is getting the ip from the dhcp but i cant ping to the internal gateway of the router or to the external network. 192.168.11.1 is the gateway. ip recived from dhcp by the instance is 192.168.11.2.

sudarshan gravatar imagesudarshan ( 2014-04-29 02:07:13 -0500 )edit

info: initramfs: up at 0.72 GROWROOT: CHANGED: partition=1 start=16065 old: size=64260 end=80325 new: size=2072385,end=2088450 info: initramfs loading root from /dev/vda1 info: /etc/init.d/rc.sysinit: up at 0.91 Starting logging: OK Initializing random number generator... done. Starting acpid: OK cirros-ds 'local' up at 0.99 no results found for mode=local. up 1.02. searched: nocloud configdrive ec2 Starting network... udhcpc (v1.20.1) started Sending discover... Sending select for 192.168.11.2... Lease of 192.168.11.2 obtained, lease time 86400 deleting routers route: SIOCDELRT: No such process adding dns 192.168.11.3 cirros-ds 'net' up at 1.06 checking http://169.254.169.254/2009-04-04/instance-id (http://169.254.169.254/2009-04-04/ins...) failed 1/20: up 1.07. request failed failed 2/20: up 6.11. request failed failed 3/20: up 9 ...(more)

sudarshan gravatar imagesudarshan ( 2014-04-29 02:07:27 -0500 )edit

I have Setups of Two Node Neutron OVS&VLAN (GRE) Clusters described in step by step fashion for CentOS 6.5 and F20 in my blog http://bderzhavets.blogspot.com . So, I can share only RH's based setups. I also see problem with access to metadata from your recent feedback.

dbaxps gravatar imagedbaxps ( 2014-04-29 03:10:17 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-04-28 11:22:44 -0500

Seen: 1,535 times

Last updated: Apr 28 '14