Ask Your Question
1

Problem to communicate between keystone and PostGreSQL

asked 2013-07-03 08:42:12 -0500

Ph4nToM gravatar image

updated 2013-07-04 02:22:36 -0500

Hello, I 've already installed Openstack Grizzly before with mysql. But I would like to do the same with a postgreSQL server. But I can't for the moment.

This is the procedure that I followed on PostgreSQL:

image description

image description

This is the File code that I modified on keystone.conf:

image description

When I try to communicate with the data base, I can't:

image description

Then, I tried do modified the file pg_hba.conf as sgordon said.

image description

In /var/log/keystone/keystone.log I have this error:

image description

But no result..

When I look my databases postgresql, I have the message: could not change directory to"/etc/keystone" its'strange....

image description

I decide to change the owner to put my openstackuser as the owner..

image description

But I have the same error as before..

How can I do?

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
2

answered 2013-07-03 11:54:30 -0500

sgordon gravatar image

updated 2013-07-03 11:57:15 -0500

By default Postgresql uses IDENT-based authentication. To fix this error open PostgreSQL client authentication configuration file /var/lib/pgsql/data/pg_hba.conf:

# vi /var/lib/pgsql/data/pg_hba.conf

To allow username and password based authentication append the following to allow login via localhost only (modify the host if your keystone server is remote to the database server):

local   all all trust
host    all 127.0.0.1/32    trust

Save and close the file. Force the server to reload the configuration file using pg_ctl:

# pg_ctl reload
edit flag offensive delete link more

Comments

Thanks for your help, I have edit my post

Ph4nToM gravatar imagePh4nToM ( 2013-07-04 02:10:42 -0500 )edit

Interesting, the error indicates that this is the right track but I'm not familiar enough with postgres to know what I missed in enabling password auth. It shouldn't make a difference but did you try doing a full restart of the postgres service after making the change (as opposed to just the reload)

sgordon gravatar imagesgordon ( 2013-07-04 23:01:53 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

Stats

Asked: 2013-07-03 08:42:12 -0500

Seen: 770 times

Last updated: Jul 04 '13