Ask Your Question
0

neutron-server fails to start

asked 2014-04-27 12:40:36 -0500

OldCrowEW gravatar image

I am following this guide:

http://docs.openstack.org/icehouse/install-guide/install/yum/content/neutron-ml2-controller-node.html (http://docs.openstack.org/icehouse/in...)

I try to do service neutron-server start and then nothing. No logs, no anything. Here is my sanitized config: http://pastebin.com/xwAF4yNM

Any help would be appreciated.

edit retag flag offensive close merge delete

Comments

hi, how is your set up? is it in single server or multi node server, you might need to check on your rabbit setting inside neutron.conf and make sure your bridge interface has been configured correctly. btwm is the service running ? you can check it with service neutron-server status

senyapsudah gravatar imagesenyapsudah ( 2014-04-27 19:20:32 -0500 )edit

hi, I think you miss the list of mechanism_drivers in the config file. It also worth to set debug = True.

irenab gravatar imageirenab ( 2014-04-27 23:26:39 -0500 )edit

Could you run the query :-
[root@dfw02 ~(keystone_admin)]$ mysql -u root -p
Enter password:
Welcome to the MariaDB monitor. Commands end with ; or \g.
Your MariaDB connection id is 86
Server version: 5.5.36-MariaDB MariaDB Server
Copyright (c) 2000, 2014, Oracle, Monty Program Ab and others.
Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.
MariaDB [(none)]> SELECT User, Host, Password FROM mysql.user WHERE user='neutron' ;
+---------+-----------+-------------------------------------------+
| User | Host | Password |
+---------+-----------+-------------------------------------------+
| neutron | localhost | *4DF421833991170108648F1103CD74FCB66BBE9E |
| neutron | % | *03A31004769F9E4F94ECEEA61AA28D9649084839 |
+---------+-----------+-------------------------------------------+
2 rows in set (0.00 sec)

dbaxps gravatar imagedbaxps ( 2014-04-28 04:04:59 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
1

answered 2014-05-17 00:28:23 -0500

OldCrowEW gravatar image

Believe it or not it was a space before "verbose = True" Thanks for everyones help.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2014-04-27 12:40:36 -0500

Seen: 2,000 times

Last updated: May 17 '14