Ask Your Question
0

I can ping private IP. but I can't ping floating ip

asked 2014-04-26 09:39:16 -0500

anonymous user

Anonymous

updated 2014-04-30 08:32:57 -0500

Hi experts,

Environment: Centos6.5+RDO+havana

I create a instace successfully with (public ip:192.168.226.101,private ip:10.10.10.2). I can ping private ip but I can't ping public ip. could some help to tell me the solution? or you can tell me how to debug this issue?

ping 10.10.10.2
PING 10.10.10.2 (10.10.10.2) 56(84) bytes of data.
64 bytes from 10.10.10.2: icmp_seq=1 ttl=128 time=9.79 ms
64 bytes from 10.10.10.2: icmp_seq=2 ttl=128 time=5.47 ms


ping 192.168.226.101
PING 192.168.226.101 (192.168.226.101) 56(84) bytes of data.

Following is my information :

[root@alpha neutron(keystone_admin)]# nova floating-ip-list
+-----------------+-----------+------------+------+
| Ip              | Server Id | Fixed Ip   | Pool |
+-----------------+-----------+------------+------+
| 192.168.226.102 |           | -          | public|
| 192.168.226.101 |           | 10.10.10.2 | public|
+-----------------+-----------+------------+------+

seems br-int is not set.

ifconfig
br-ex     Link encap:Ethernet  HWaddr 00:0C:29:03:B6:10
          inet addr:192.168.226.105  Bcast:192.168.255.255  Mask:255.255.0.0
          inet6 addr: fe80::548a:72ff:feb2:9e0b/64 Scope:Link
          UP BROADCAST RUNNING  MTU:1500  Metric:1
          RX packets:222692 errors:0 dropped:0 overruns:0 frame:0
          TX packets:11827 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:68860413 (65.6 MiB)  TX bytes:2947675 (2.8 MiB)

br-int    Link encap:Ethernet  HWaddr 12:9F:BA:29:13:43
          inet6 addr: fe80::40c:b3ff:fe53:2141/64 Scope:Link
          UP BROADCAST RUNNING  MTU:1500  Metric:1
          RX packets:33 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:2866 (2.7 KiB)  TX bytes:468 (468.0 b)
edit retag flag offensive close merge delete

Comments

Please,post formated outputs for
1. ifconfig
2.ovs-vsctl show
Source keystonerc_admin
$ openstack-status

dbaxps gravatar imagedbaxps ( 2014-04-26 09:57:56 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
1

answered 2014-04-30 07:53:44 -0500

libosvar gravatar image

That is probably because you have no route to your private subnet. You should be able though to ping private ip from router's namespace. (ip netns exec qrouter-<namespace_id> ping 192.168.226.101)

edit flag offensive delete link more

Comments

Does this answer work for you ? I believe it's not the first time you are posting this question on the site.
I guess first time you have asked is right here. You were also changing Ethernet device names. Are you aware how to do this properly ?
Link is here

DanIzack gravatar imageDanIzack ( 2014-05-01 00:35:10 -0500 )edit

seems this solution doesn't not work for me. I check with an expert in another tpoic.

alphazhang gravatar imagealphazhang ( 2014-05-01 02:08:26 -0500 )edit

have you create a ping rule in Security Groups, ICMP rule for Ping ? You will need this to reach it from the public side.

Bill@Metacloud gravatar imageBill@Metacloud ( 2014-05-04 17:45:16 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2014-04-26 09:39:16 -0500

Seen: 2,501 times

Last updated: Apr 30 '14