Ask Your Question
0

Can't find roles tab on dashboard..

asked 2014-04-26 09:18:08 -0500

pkumar gravatar image

Hi,

I've deployed icehouse release of openstack. I can create roles through command line but on dashboard that option is missing. Documentation at http://docs.openstack.org/user-guide-admin/content/section_dashboard_admin_manage_roles.html (http://docs.openstack.org/user-guide-...) says that there is a Roles category on Admin tab but I can't find it.

Any help?

Thanks, Pradeep

edit retag flag offensive close merge delete

2 answers

Sort by ยป oldest newest most voted
2

answered 2014-04-28 08:28:24 -0500

jpichon gravatar image

The roles page is only available when working with Keystone v3. If you have the v3 API deployed, you can set Horizon to use it by updating the identity version in the OPENSTACK_API_VERSIONS setting, see https://github.com/openstack/horizon/... . The OPENSTACK_KEYSTONE_URL should also be updated.

edit flag offensive delete link more

Comments

That's very helpful to know. I'll check today & update here the outcome. Thank you for the guidance !!

pkumar gravatar imagepkumar ( 2014-04-28 10:09:54 -0500 )edit

After modifying OPENSTACK_API_VERSIONS & OPENSTACK_KEYSTONE_URL, Roles and groups are visible in admin tab. Thanks for the answer!!

pkumar gravatar imagepkumar ( 2014-04-28 12:05:14 -0500 )edit

Glad that helped!

jpichon gravatar imagejpichon ( 2014-04-29 02:55:38 -0500 )edit
1

Issue I ran into as well with Havana, if you are using more than 8 api endpoints make sure you uncomment the header line length:

max_header_line = 16384

That way you can work with the v3 api and not run into issues with auth due to tokens that are too big.

mpetason gravatar imagempetason ( 2014-05-01 09:08:03 -0500 )edit

No, I'm not facing any issues with dashboard now after changing what jpichon suggested. I've 12 endpoints and passwords are like 20 characters long. So all good there...

pkumar gravatar imagepkumar ( 2014-05-01 11:48:26 -0500 )edit
0

answered 2014-12-25 03:31:38 -0500

Glen.GZ gravatar image

thanks for you tip. I uncommented OPENSTACK_API_VERSIONS = { "data_processing": 1.1, "identity": 3, "volume": 2 }

and set OPENSTACK_KEYSTONE_URL = "http://%s:5000/v3.0" from v2.0 now i can see the role page.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-04-26 09:18:08 -0500

Seen: 1,123 times

Last updated: Dec 25 '14