Ask Your Question
0

when run cmd "neutron agent-list" show the message "connection to neutron failed:Maximum attempts reached"

asked 2014-04-26 02:52:39 -0500

clp gravatar image

after show that message,I restart neutron-server,but the cmd "service neutron-server status" show "neutron-server stop/waiting". who can tell me where is wrong?

edit retag flag offensive close merge delete

Comments

What says your analog of
$ systemctl list-units | grep neutron
Source keystonerc_admin to run
$ openstack-status

dbaxps gravatar imagedbaxps ( 2014-04-26 03:07:38 -0500 )edit

4 answers

Sort by » oldest newest most voted
0

answered 2014-04-30 13:58:23 -0500

I got the same error.. While problem was that neutron server was not able to start. Reason for neutron-server to fail to start was i had few extra spaces in configurations in neutron.conf file.

edit flag offensive delete link more
0

answered 2014-04-26 03:37:28 -0500

clp gravatar image

I use ubuntu12.04,there not have other information,I check /var/log/neutron/server.log and server.log.1 not find information,neutrion-server just seem not run.

edit flag offensive delete link more
0

answered 2015-01-25 20:54:05 -0500

Pulak gravatar image

hi, I am also getting the same issue, can you please let me know how did you solve this issue? I checked there were no extra spaces in neutron.conf file.

edit flag offensive delete link more

Comments

well, just figured out that it was an issue with the message broker where the password was wrong for the rabbitmq user id. I just changed the password of guest and changed the configuration file according and it started working. Thanks.

Pulak gravatar imagePulak ( 2015-01-25 22:40:30 -0500 )edit
-1

answered 2014-04-26 03:12:33 -0500

dbaxps gravatar image

updated 2014-04-26 03:15:14 -0500

Shoud be

[root@dfw02 ~(keystone_admin)]$ service neutron-server status
Redirecting to /bin/systemctl status  neutron-server.service
neutron-server.service - OpenStack Neutron Server
   Loaded: loaded (/usr/lib/systemd/system/neutron-server.service; enabled)
   Active: active (running) since Sat 2014-04-26 11:03:01 MSK; 1h 6min ago
 Main PID: 1232 (neutron-server)
   CGroup: /system.slice/neutron-server.service
           └─1232 /usr/bin/python /usr/bin/neutron-server --config-file /usr/share/neutron/neutron-dis...

What says your analog of
$ systemctl list-units | grep neutron
Source keystonerc_admin to run
$ openstack-status
edit flag offensive delete link more

Comments

Thanks very much, the problem is resolve,the reason is vmware plug-in.

clp gravatar imageclp ( 2014-04-26 04:03:30 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-04-26 02:52:39 -0500

Seen: 1,087 times

Last updated: Apr 30 '14