Ask Your Question
0

Error 500 when loading OpenStack Dashboard

asked 2014-04-25 17:17:25 -0500

TD-Roy gravatar image

updated 2014-04-26 08:35:56 -0500

We are configuring Icehouse On SLES 11 SP3 3 Node Architecture 1Node = Controller 1Node = Compute 1Node = Dashboard

All hosts can reach one another as well my machine on a different network.

/var/log/apache2/openstack_dashboard_error.log:

[Fri Apr 25 15:02:53 2014] [error] [client 153.64.146.152]   File "/usr/lib64/python2.6/site-packages/django/conf/__init__.py", line 128, in __init__
[Fri Apr 25 15:02:53 2014] [error] [client 153.64.146.152]     mod = importlib.import_module(self.SETTINGS_MODULE)
[Fri Apr 25 15:02:53 2014] [error] [client 153.64.146.152]   File "/usr/lib64/python2.6/site-packages/django/utils/importlib.py", line 40, in import_module
[Fri Apr 25 15:02:53 2014] [error] [client 153.64.146.152]     __import__(name)
[Fri Apr 25 15:02:53 2014] [error] [client 153.64.146.152]   File "/srv/www/openstack-dashboard/openstack_dashboard/wsgi/../../openstack_dashboard/settings.py", line 219, in <module>
[Fri Apr 25 15:02:53 2014] [error] [client 153.64.146.152]     from local.local_settings import *  # noqa
[Fri Apr 25 15:02:53 2014] [error] [client 153.64.146.152]   File "/srv/www/openstack-dashboard/openstack_dashboard/wsgi/../../openstack_dashboard/local/local_settings.py", line 108
[Fri Apr 25 15:02:53 2014] [error] [client 153.64.146.152]      'LOCATION' : '127.0.0.1:11211'
[Fri Apr 25 15:02:53 2014] [error] [client 153.64.146.152]                 ^
[Fri Apr 25 15:02:53 2014] [error] [client 153.64.146.152]  SyntaxError: invalid syntax
[Fri Apr 25 15:04:19 2014] [error] [client 153.64.146.152] mod_wsgi (pid=7356): Exception occurred processing WSGI script '/srv/www/openstack-dashboard/openstack_dashboard/wsgi/django.wsgi'.
[Fri Apr 25 15:04:19 2014] [error] [client 153.64.146.152] Traceback (most recent call last):
[Fri Apr 25 15:04:19 2014] [error] [client 153.64.146.152]   File "/usr/lib64/python2.6/site-packages/django/core/handlers/wsgi.py", line 187, in __call__
[Fri Apr 25 15:04:19 2014] [error] [client 153.64.146.152]     self.load_middleware()
[Fri Apr 25 15:04:19 2014] [error] [client 153.64.146.152]   File "/usr/lib64/python2.6/site-packages/django/core/handlers/base.py", line 46, in load_middleware
[Fri Apr 25 15:04:19 2014] [error] [client 153.64.146.152]     for middleware_path in settings.MIDDLEWARE_CLASSES:
[Fri Apr 25 15:04:19 2014] [error] [client 153.64.146.152]   File "/usr/lib64/python2.6/site-packages/django/conf/__init__.py", line 54, in __getattr__
[Fri Apr 25 15:04:19 2014] [error] [client 153.64.146.152]     self._setup(name)
[Fri Apr 25 15:04:19 2014] [error] [client 153.64.146.152]   File "/usr/lib64/python2.6/site-packages/django/conf/__init__.py", line 49, in _setup
[Fri Apr 25 15:04:19 2014] [error] [client 153.64.146.152]     self._wrapped = Settings(settings_module)
[Fri Apr 25 15:04:19 2014] [error] [client 153.64.146.152]   File "/usr/lib64/python2.6/site-packages/django/conf/__init__.py", line 128, in __init__
[Fri Apr 25 15:04:19 2014] [error] [client 153.64 ...
(more)
edit retag flag offensive close merge delete

Comments

1

can you set your allowed host to below?

ALLOWED_HOSTS ="*"

and restart your web server again, btw, make sure memcache is running if you configured dashboard to work with memcached.

senyapsudah gravatar imagesenyapsudah ( 2014-04-26 00:11:03 -0500 )edit

1 answer

Sort by ยป oldest newest most voted
1

answered 2014-04-28 07:35:42 -0500

jpichon gravatar image

There should be a comma at the end of the BACKEND line:

CACHES = {
    'default': {
        'BACKEND' : 'django.core.cache.backends.locmem.LocMemCache',
        'LOCATION' : '127.0.0.1:11211'
    }
}

This is because the settings file is a Python file and must have correct Python syntax. In a dictionary, Python expects each attribute (here, 'BACKEND' and 'LOCATION') to be separated by comma.

edit flag offensive delete link more

Comments

That did it. Wow, really appreciate it. Oversight on my part. Its there in the documentation I guess I accidentally removed it while playing with the code.

Thank you

TD-Roy gravatar imageTD-Roy ( 2014-04-28 10:20:32 -0500 )edit

Glad the problem is resolved!

jpichon gravatar imagejpichon ( 2014-04-29 02:56:19 -0500 )edit

very helpful. Thanks you a lot !

Xanion gravatar imageXanion ( 2014-09-14 07:24:45 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

2 followers

Stats

Asked: 2014-04-25 17:17:25 -0500

Seen: 2,945 times

Last updated: Apr 28 '14