Ask Your Question
1

Famous Glance HTTP500 error. I believe I have things configured correctly. Help a brother out!

asked 2014-04-24 13:10:40 -0600

virtualGain gravatar image

updated 2014-04-24 14:33:40 -0600

I have combed over these configs 20 times. I must be ignorant to something. I am also positive that my passwords are not fat fingered or anything. I am trying to install Icehouse via the openstack guide on Centos6.5. I will <3 the person that can solve this.

[root@mdd-horizon1 images]# glance image-create --name=cirrosImage --disk-format=qcow2 --container-format=bare --is-public=true < cirros-0.3.2-x86_64-disk.img Request returned failure status. HTTPInternalServerError (HTTP 500)

configs http://paste.openstack.org/show/76985/

glancelogs http://paste.openstack.org/show/76986/

keystonelogs http://paste.openstack.org/show/76987/

I even set the password for the glance service in keystone by using a variable directly form glance conf, see below. MYPASS=$(eval openstack-config --get /etc/glance/glance-api.conf keystone_authtoken admin_password) [root@mdd-horizon1 ~]# echo $MYPASS mypass [root@mdd-horizon1 ~]# keystone user-password-update --pass $MYPASS glance

Still doesn't work.. QQ

edit retag flag offensive close merge delete

1 answer

Sort by ยป oldest newest most voted
0

answered 2014-04-24 13:24:03 -0600

dro gravatar image

it says right there bro, keystone and glance authorization failed, you need to make sure your glance configs have correct password specified for the admin id "glance" . You can change the glance user password. I'm still learning, but I had this issue for another service and I verified the password in the config file and changed it and also changed the glance admin user id password

make sure you know the password in /etc/glance/

list the users

  1. source the admin file

keystone-user list

| c23a77f5dd914e91915f20ff857b9b1c | admin | True | alex@ | 0d6e2a40e2024a7b9320f38c73384dea | demo | True | demo@ | e68f204570664dd1a00fd17656291075 | glance | True | glance@ < -- | 09bd71defdd84b06bde6ea1bbeedce6a | neutron | True | neutron@ | 1be47cc87e524122b423fc2d4a6d9a86 | nova | True | nova@

keystone user-password-update --pass <newpassword> glance

then try it again, hope it helps.

edit flag offensive delete link more

Comments

I have definitely thought of that and triple checked that my glance pass is correct. See output below. Still returns same errors after restarting services. The token-get at the bottom returns successfully though. That's what is not making sense. I know i can log in with the creds that are specified in the glance conf.

keystone user-password-update --pass mypass glance

openstack-config --get /etc/glance/glance-api.conf keystone_authtoken admin_password

mypass

keystone --os-username=glance --os-password=mypass--os-tenant-name=service token-get

virtualGain gravatar imagevirtualGain ( 2014-04-24 13:33:12 -0600 )edit

grep admin_password from /etc/glance/* see if they all match what you changed it it with the keystone user-password-update

I don't see what else it could be.

dro gravatar imagedro ( 2014-04-24 17:16:21 -0600 )edit

I have same issue in Devstack, where stack.sh script creates keystone account for glance but HTTP 500 issue in Icehouse. But Glace works in havana without issues. link

SGPJ gravatar imageSGPJ ( 2014-04-25 03:26:48 -0600 )edit

How can a first install of Devstack fail in Icehouse but work in Havana?

SGPJ gravatar imageSGPJ ( 2014-04-25 03:27:36 -0600 )edit

I dont know man I think I am just going to try this on Ubuntu or something .. :(

virtualGain gravatar imagevirtualGain ( 2014-04-25 10:11:33 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Get to know Ask OpenStack

Resources for moderators

Question Tools

1 follower

Stats

Asked: 2014-04-24 13:10:40 -0600

Seen: 278 times

Last updated: Apr 24 '14